Changing height of AI agent to work in Navigation Mesh

Hey Guys,

I have an AI agent (derived from ACharacter) that works perfectly when i use MoveToLocation if its capsule height is 88.0 and radius is 39.0. My issue is when I double the size to 196 height and 78 radius (so that I can double the scale of Skeletal Mesh), the MoveToLocation no longer works. I tried to fiddle with the Recast Navmesh settings, but it didn’t really help. Can some help me with this?



I’ve tried this before and the only ‘gotcha’ I found was that my entities ended up getting spawned slightly under the NavMesh once i increased their bounds. Perhaps this is your problem?

I actually thought of that too. So I spawned my antimatter way above the ground and let the gravity do its job :P. But I do see your point. Maybe I should try some custom z positions.

Hey, have you tried creating a second Navigation agent in “Project Settings > Navigation System > Agents”, and set the second agents radius/height to your new character size. This should auto-create (when navigation rebuilds/ or close/reopen project) a new Navmesh bounds volume in your level that fits the new agent dimensions.

I think (the last I heard), the navigation system then automatically picks the best fit navmesh bounds volume for your character based on the characters size (you might have to ask someone else here for more details on the sepcifics tho (what size it uses, collision capsule, movement component details etc…)…