Changing game instance causes crash

I created a new game instance, which I later changed name of. This made it not show up in ‘maps and modes’ - selection showed ‘none’ now instead which made my game crash upon launch every time.

Moving my game instance to another folder also made game instance pulldown show ‘none’ in maps and modes with same crash.

I use 4.5.1 in win7.


If you change name of class, be sure you also change name of files and vice versa.

Also, you can manually set GameInstance class in your game DefaultEngine.ini :


Hi RumbleMonk,

I was able to reproduce this and have logged a bug in our database for developers to look over (UE-6040). I will let you know when I see an update on it. In meantime, you’ll need to make sure to update Project Settings > Maps & Modes > Game Instance Class setting anytime you rename or move GameInstance you are referencing there. Thanks for report!

Its still not fixed. editor crashes

Hi Azarus,

That’s correct, bug is still open on our end. There has been some discussion on what’s causing issue and how to fix it, but it hasn’t been looked at for a little while. I’ve increased community interest for it and emailed team looking into it. I will update this post when I see any progress on it. For now, make sure you’re updating Project Settings anytime you rename GameInstance. Thanks for your patience!

Hi, I encountered same problem in version 4.8.1.

I have created a Blueprint of a Game Instance and whenever I load project it is not selected, even If I change DefaultEngine.ini

Whenever I load project settings and try to change Game Instance it crashes but I found a workaround: If you load world settings in editor and select a different game mode then you can go to Project Settings and change game instance.

I hope this bug gets fixed…

This workaround worked for me in 4.8.1. I had same issue as OP.

I tried this workaround and solve my problem:

My BP’s names are similar to: “BP_MyNewGameMode”. Well, I changed name to “GameInstance2” and for some reason, worked. We are in 2017, my version is 4.16.3 and still have this issue.

Epic Games is working too much for new features to increase revenue with AAA companies and forget to fix these crazy bugs.