Changing from a NON VR map to a VR map performance drop


I have 2 maps, 1 non VR, and 1 that is optimised for VR. By default it is in the non VR mode, when I switch to VR mode I open the VR map and I am getting bad performance. But if I start the application in the VR mode I am getting 90FPS.

I have tried using the Openmap blueprint node and the console command to try to switch between levels and I am still getting the performance drop.

Hello Imsopov,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved?

Thanks for the reply.

  1. I have copied the maps to a new project and still get the same result.

  2. I did have some information loading on the level load but I have stripped it back to the bare basics and still have the same problem.

  3. The blueprints could not get more basic if it tried.

Non VR level

On the load of the VR Map

I was unable to reproduce this issue on our end. I did not see a difference in performance while switching between levels (to a level with enable HMD). How much of a frame drop are you seeing when switching between levels? If you use identical levels does this issue still occur?

When the VR level is loaded first I get 90 fps, if not I am getting around 40-50 on a GTX 1080. I originally did have the same level for VR and non VR but because of the dynamic lighting (time of day feature) in our non vr map we optimised and used static lighting.

I have a couple of more questions for you.

Additional questions:

  1. What VR device are you using when this issue occurs?
  2. What OS are you you currently running on the machine being used for VR testing?


Windows 10
GTX 1080
32 GB ram

With the additional information provided I was able to find that this appears to be a known issue. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-30406)

Make it a great day

Thanks for spending your time on this. At least it can be replicated.

Just a quick one, it says this bug was resolved Jan 12, does this mean it will be fixed in 4.15? It says 4.16 on the bug tracker?

The target fix is the current estimated version that the solution will be integrated into. In this case it is currently estimated that it will be 4.16. I hope that this information helps.

This problem has still not been fixed in 4.16

Reprojection kicking in when you don’t hit framerate (90) and pulling you back to 45 is intended. The issue that was resolved was the choppiness that was being seen once the drop occurs. You may drop to 45, but it’s still nice and smooth due to the interleaving of frames. I hope this information helps.

Make it a great day

Hi Rudy,

This still doesn’t fix my problem. This exact same map runs at 90fps, if I launch directly into it in VR. If I load my project in non vr mode then enable the hmd I get 45

When it drops to 45, does it stay at 45 and go back up to 90 eventually or does it stay at 45 fps?