Changing Engine Directory

Hi there,

I want to ensure this issue is not confused with changing the location for where the content/marketplace items are downloaded.

I’m speaking about the actual 4.1, 4.2 directories that contain the engine itself - these are approximately 10GB each.

I have them both downloaded, however I want the launcher to pick them up/detect that I already have them downloaded instead of it saying “No Engine Installed”.

Is there a way I can do this? Right now they’re sitting in the following location: K:\Program Files\Unreal Engine\4.1 and 4.2. This is also where the launcher is located (K:\Program Files\Unreal Engine\Launcher).

Thanks again!

Hi dolsson,

There is a trick you can use to make the Launcher find the engines, and simply just verify the files locally. There will of course be some download if the engines already located there are not exactly the latest version, but hopefully you won’t have that problem.

Firstly, navigate to "C:\ProgramData\Epic\UnrealEngineLauncher\Data\Manifests" and make sure there are no existing manifest files otherwise the Launcher may look elsewhere for the engine installations when installing them.

Then, navigate into the 4.1 and 4.2 folders and create an empty file named exactly “$movedMarker”, no extension. e.g. you should have K:\Program Files\Unreal Engine\4.1$movedMarker

You need to do that for both of the engines you put there.

When you hit the install button on the engine version you placed the $movedMarker in, the installation should show a “Verifying” instead of “Downloading” after it has finished initializing. At the end of the Verifying stage, if all seems in check then it’ll be done, otherwise some data may be downloaded to ‘fix’ the installation files that were detected as incorrect.

Let me know how you get on!

That worked wonderfully!

Thank you very much, I’m very happy!

Awesome news! Have fun :slight_smile:

i’m just move directories, after this

  1. “C:\ProgramData\Epic\EpicGamesLauncher\Data\Manifests” delete manifest file;

  2. change install location in file LauncherInstalled.dat in parent folder’s (EpicGamesLauncher & UnrealEngineLauncher)

  3. run launcher: he write “Not downloaded” - click install - first it “Download” after “Verifying”

  4. i don’t know need that or not, but i’m change all old directories to new in win registry

Awesome trick Swifty ! Thanks.

I would recommend to implement a more elegant system in the launcher, so all of us who were forced to move the 80go of engines to another Disk wouldn’t freak out :slight_smile:

so the point of download ark devkit in steam is what? worthless?
I have to download another 80gb ?

Hey Belnick,

For any questions, concerns, or feedback regarding the Epic Games Launcher, please visit http://help.epicgames.com/ for additional support. You can use the Email Us button under the Contact Us section to get in touch with one of the support staff who will be able to assist you further, answer any questions, and take feedback that you may have.

Have a great day!

great days does not exists, but ok then thx

IHello, I just reinstall win8.
I had a previous installation of UE 4.12 and 4.15
The launcher dosn’t see them and want to download again everything…

I look at the “C:\ProgramData\Epic\EpicGamesLauncher\Data\Manifests” folder but I have no “Manifests” folder in it, just a something.manifest file that I delete.

I add the empty “$movedMarker” in my UE_4.15 and UE_4.12 folders.

When I click on the install button, i can set the folder where I want the engine to be installed but if I choose one of these two (UE_4.15 or UE_4.12, witch contain the previous install and the empty file), The launcher give me the error “the folder have to be empty” and the install button stay grey and unclickable…

Is there a new way to do this ?

Hello,

Please visit http://help.epicgames.com/ for issues or concerns with the Epic Games Launcher. You can use the Email Us button on the side of that page to get in touch with one of our support staff.

Have a great day

If anyone have problems after reinstalling Windows, EpicLauncher ,Changing Engine Directoryor other situations through which You do not “have Installed” Engine and Epic Launcher don’t recognising already installed Engine files then…

  • #1 Shut off Epic Launcher

  • #2 Make copy or move your current engine folder anywhere you want , but do not corrupt it…

  • #3 Relaunch Epic Launcher and start downloading instalation of Engine version what you had previously in the same folder location… - with all installation options selected previously

  • #4 Wait until Epic Launcher start downloaing , then pause and open Task manager (ctrl+alt+del) and force stop Epic Launcher.exe

  • #5 then delete new created folder with downloaded data and copy or move YOUR previously moved FOLDER to this loaction (this must be the same version of Engine)

  • #6 Remember to choose only that options what you choosen when you installing Engine , because if you do not manage what don’t you choose in installation options then you must to download ALL selected packges (Look at point #3)
    (FOR EXAMPLE : I forget to deselect Android and IOS packages…) And must start all over again whole this operation ,because I would have to download extra 3GB…
    I think I help somebody…

Thanks my brudda, it works