Changing Distance Field Resolution Scale of a mesh locking the system


I have downloaded 4.3 Preview release via the launcher and i’m having this issue.

  • Enable Distance Field AO in Project Settings > Rendering
  • Restart the editor
  • Add a skylight, directional light and atmospheric fog into the level. Set the light and skylight to movable. Enable Force No Precomputed Lighting in world settings.
  • Place some static meshes into the level from starter content
  • Hit Play > Everything works fine
  • Open up one of the meshes in the content browser
  • Change distance field resolution scale to whichever value you like
  • Go back to the level > Hit Play > the whole system freezes and i have to restart the computer

I also tried this with some static meshes i imported and still got the same result. And since the editor isn’t actually crashing i have no crash logs.

My system is;



GTX 460

Windows 7(64 Bit)

Let me know if you need more info.


This is still happening with today’s 4.3 release.

Howdy Jacky,

I was running some tests and may have found a shorter way to reproduce this issue. Do not enable the Force Precomputed Lighting. Also, Do not place any static meshes or alter any previous ones that are in the level.

I am am able to play the first 2 times, but on the third, it will cause a crash.

I just wanted to check in with you and see if this is the same error you are seeing before I write up a bug report for the issue.

Thanks and have a great day!

Hey Sean!

Thanks for looking into this.I forced myself to give it another go last night(I can’t test this too often since i dont want to reset the computer every time) created an FPS BP project, I didnt change the resolution scale of any mesh, enabled Force No Precomputed Lighting, and it froze the first time this time. There is an inconsistency but there is definitely something causing this freezing with DFAO. I first ran into this with an empty level so i dont think it is related to existing BSP brushes or physics enabled cubes in the FPS level.

As i said i really dont want to test this anymore but i can try one more time if you want me to. Or i can post in the forum and ask help from others. Let me know.

Thanks again!

Don’t sweat it Jacky. I just tested it again and can consistently reproduce the issue so I am just going to fill out a bug report for the issue. I have be assigned to multiple user with the same issue, so I can see this being a large issue.

Thanks again and have a great day!

Both happy and sad news for me then, but glad it is going to be fixed!

Thanks. :slight_smile:

Hello again!

I thought i should let you know that after several tries with no crash this issue does not occur in 4.5. :slight_smile:

Thanks Epic!