Download

Changing a struct's properties causes output log errors

I recently tried changing a struct, specifically one of its properties from a set to an array. After I saved the change all blueprints where that struct was being used logged an error alerting me to an “Unknown structure”. When I opened one of the erroring files I could see all of the references to the struct seemed to be correct with the new property. The blueprint compiled correctly when I tried and I had no issues saving. However, the error persists until I selected the “Refresh All Nodes” option on the blueprint.

The errors persist even after I restart my editor.

I found this community post describing the issue: Changing Structure breaks Blueprint and DataTable - UE4 AnswerHub
It links this issue: Unreal Engine Issues and Bug Tracker (UE-40033) which is marked as fixed. The blueprint compiles, but there is still an error in the output log.

I would expect no errors if there are no compile issues. It is a little bit jarring to have the output point to an error and then have the file compile perfectly. It took some time to realize that refreshing all nodes was how to fix the issue, so perhaps surfacing that might help provide clarity to the user.