Changes to Skeleton in Persona won't save!

I’ve seen a couple people with this issue but I thought it would be fixed in 4.7.
I simply made some skeleton changes to my character’s blueprint in order to properly align her hands. However no matter what I do, the changes aren’t ever updated in the game!

I’ve set the character to “Update Joints from Animation” which had previously worked. But now, even if I’ve edited my animation and saved it, it does not update and looks like it did before the change. What can I do to fix this?

So I found one way to make it work.


Since this was a direct bone rotation (transformation) I decided to try clicking this button. After saving it worked and I realized why. I assume this is the action I need to perform to perform bone transformations. If there’s another method you can comment as well. But for anyone who had a similar problem, here is a fix.

It’s weird I Donno what I’m doing wrong but sometimes it works sometimes it doesn’t. Maybe I need to not click apply? Should we click apply?

Hit what button? i cant see the link you send

Hey @Faze_Kaas,

We recently moved answerhub over to the Unreal Engine forums so some of the links are broken but we’re working to resolve all issues! If you still need help, feel free to make your own thread and you might be able to get a better answer.

Also, welcome to the Unreal community! :slight_smile: