Change scale to meters for blueprints functions ( not only displayed units)

I know there is a project setting Editor - > Appearance → Distance/Length, but this only appears to make the transform nodes display in meters instead of centimeters when selecting objects. My blueprints still use centimeters for all the functions (SetActorLocation, AddLocalOffset, etc…). Is there any way to change that as well so I don’t need to add 2 zeros to every value I work with? It makes all my variables (speeds, locations, offsets, etc) less readable with 2 zeros tacked on for nothing.


I don’t thinks there a option for that.

Most nodes are direct bindings to C++ functions and varables, they accept what they accept entire engine operates in 1cm bases, the option you using only hides that. I can see this possible to implement in default arguments values and you could post a feture request in feedback forum, but it won’t change fact that nodes and especially C++ code that powers them will still operate in cm.

Did you ever figure this out? I am having the same issue. Thanks!

That makes sense. Be nice if they could find a way around that. Thanks!

2023 and still cm in blueprints even if the project settings are setted to meters