Change C++ engine source location

I have exactly same problem as in that was marked as “Cannot Reproduce”.

I’ve installed Unreal through Epic Games Launcher, with Editor Source and symbols selected. Unreal is downloaded to C drive but I have one game on D drive. Is it somehow possible to change that “D:\build++ue4+release-4.25+compile\sync\engine\source” path in editor preferences? I have correct files in “C:\Unreal\UE_4.25\Engine\Source”