Change animation to "stay-on-the-same-spot"

I have a character with walking animation, at the end of the animation, the character would have traveled forward some distance. How to i remove the travelling distance, while keeping the actions of the hands and legs walking.

In other words, how do i change the moving animation to a “stay-on-the-same-spot” animation, without messing with the walking gestures.

Open your animation sequence from the content browser, click the asset details tab, scroll down to the root motion section, and place a tick in enable root motion. :wink:

1 Like

You can either turn on Root Motion where the Animation drives Velocity/Translation in the world or you could enable Force Root Lock which disables the Root Motion, the animation is in-place and you move the Pawn separately
You find the settings in your AnimSequence Asset Editor.

Hi, it’s been years since this was answered, but what should I do if I turned on the Root Motion and enabled Force Root Lock, but none of them worked, and my animation keeps moving forward? By the way, when I checked the animation, it seems the root NEVER moves, but the animation does for some reason.