Download

CDO Constructor: Failed to Find - (ThirdPerson C++ Template Mannequin AnimBP)

I am trying to load the original ThirdPerson C++ Template Mannequin AnimBP file.

The following line works properly in editor (UE4.17.1), but somehow throws a ‘CDO Constructor: Failed to Find’ error in packaged game.


static ConstructorHelpers::FObjectFinder<UAnimBlueprint> AB_Asset(TEXT("/Game/Mannequin/Animations/ThirdPerson_AnimBP.ThirdPerson_AnimBP"));

Please note that;

  • I made NO modifications on the original ThirdPerson template anim files,
  • properly defined the directory to be included in DefaultGame.ini using +DirectoriesToAlwaysCook,
  • set bDontLoadBlueprintOutsideEditor flag to False in DefaultEditor.ini,
  • and, checked the Packaging log file. The files that I’m trying to load are properly cooked in package.

As an alternative to static FObjectFinder method, I also tried to load the same AnimBP file using FStreamableManager Sync/ASync loaders. The file is properly loaded, but ResolveObject() somehow fails to generate a valid object.

Any ideas?

OK, solved it!

Adding “_C” at the end of filename and treating the file as a “UClass” makes things run smoother. Now it runs properly on both editor and packaged game.


static ConstructorHelpers::FObjectFinder<UClass> AB_Asset(TEXT("/Game/Mannequin/Animations/ThirdPerson_AnimBP.ThirdPerson_AnimBP_C"));

@matahari Man you’re a legend, thank you so much.

For months I was struggling to find a solution for this, and now your approach worked perfectly, smoother as you said.

Again, I really appreciate your help.