CDO Constructor: Failed to find Blueprint (UE 4.4)

Hello, i have this error after create the FirstPersonMesh in the “FirstPersonShooter Example”.
example from here

This error comes only if i launch the game, not in editor with play.

Error: CDO Constructor: Failed to find Blueprint’/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2’
But this BP exists…

The copied reference is: “Blueprint’/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2’”

In the AFPSGameMode constructor:

	// set default pawn class to our Blueprinted character
static ConstructorHelpers::FObjectFinder<UBlueprint> PlayerPawnObject( TEXT( "Blueprint'/Game/Blueprints/BP_FPSCharacter2.BP_FPSCharacter2'" ) );
if ( PlayerPawnObject.Object != NULL )
	DefaultPawnClass = (UClass*) PlayerPawnObject.Object->GeneratedClass;

Play in editor works fine, but after hit ‘launch’ prints this error.
The editor show this BP in the “Scene Outliner” as active actor called “BP_FPSCharacter2_C1”.

I found some older answers; add “_C” to BP finder - but then is this BP not found in editor AND after launch.
Can anyone help me please?

BTW - i make the same example with UE 4.3.1 and this works fine!
Make again in 4.4 and launch failed again with same error.

I ran into something similar to this where it wouldn’t find blueprints when I deployed to Android. Hopefully the fix is the same for you: in your project/Config folder look for DefaultEditor.ini, change bDontLoadBlueprintOutsideEditor=true to bDontLoadBlueprintOutsideEditor=false.

Hello Naremus - thank you very much, your solution fix my problem!
Now works fine for me. :slight_smile:

Right answer is here:

We shouldn’t load UBlueprint, but directly its UClass wich is generated from actual blueprint, I suppose.

As stated MulleDK19:

For Blueprint’/Game/dice/D4_Dice_BP.D4_Dice_BP’

The class reference is Class’/Game/dice/D4_Dice_BP.D4_Dice_BP_C’

Note that menu item ‘Copy Reference’ non working good for that and shoud be fixed some day :slight_smile:

My problem with Android packaging was solved by this approach.

I think we shouldn’t walk this way. See my answer below

Thaks. This answer is really the best and the right one.

Note you have to add a _C (which is the class name of the blueprint) at the end of the ref!

1 Like

Thanks! I tryed a lot of ways and none worked until i added _C at the end of refrence path.

const FString AnimationInstanceAsset = TEXT("/Script/Engine.AnimBlueprint'/Game/Characters/Mannequins/Animations/ABP_Manny.ABP_Manny_C'");

const TSoftClassPtr<UAnimInstance> CAnimInst(AnimationInstanceAsset);

Hi I have same problem just yet and the solution is in mine ;

Go to GameMode.cpp and change the line that belongs to file path to Wherever your main character’s file path is For example;