Download

CC3 Shoe Mesh Maps Flip Inside Out in Unreal Engine

I made some shoes (short boots) using the correct technique, on a neutral base, in Blender, Zbrush and Substance Painter. The boots work perfectly in iClone and CC3.

When I export my character to Unreal Engine (using the correct plugins), the surface of the boots are all messed up. I am guessing that the mesh maps are being flipped during the export. Any idea what’s going on here and how to fix it?

I have a new PC with an I9-9900KF CPU, 32 GB of ram, and a 2080ti GPU

… your pc specs have little or nothing to do with it (however if you plan on using world creator / tiles in your project, i suggest you snag more ram. Max it out).

I honestly cannot tell in this view if this is a case of flipped normals or not.
but it does sort of look like it.

put the shoes in blender and enable the normal view. If they are pointed outside, than the next thing to look at is the material.

Now, while im at it. If those are flipped normals. What is the purpose of having 2 layers on a character shoe other than adding a lot of weight to it? None… no one will ever see the inside. I would suggest removing it.
Less poli = better product = better performance.

Btw, if you higheight the shoe material in unreal and zoom in you may be able to see if the normals are flipped. The outline will be present but the surface won’t be visible.

you can make the material double sided, but you really should fix your normals if they are it.

Just an idea: Unreal uses DirectX Normal maps not OpenGL.

Remove hidden mesh in cc3 during export might help?

Thanks! I did go back into CC3 and hid the character mesh below the top of the boots. Also checked delete hidden faces on export. I went back into CC3 and did a Flip Y on the normal maps, and reexported, but that didn’t help. The mesh still looks screwed up in UE (and not in CC3 or iClone). Is it possible that this is a scale problem coming from Blender? By the way, here’s what the mesh looks like in Blender - pretty clean topology.

And here it is in UE

2 things.
Eneable Normal view for the faces in blender, take a screenshot and share…
then another in Wireframe view.

The topology shown in UE4 seems different at a glance. The ring at the top is much more pronounced. So its entierly possible that you still have flipped normals

Okay, so I exported from CC3 to Blender, this is the same model that I am sending to UE. Here are some screencaps:

What is the material looking like? Sometimes CC3 materials are messed up after import.

I’m not sure what you would like to see as an example. What can I take pictures of?

The model looks ok.
Which could also mean that it isn’t correctly weight painted to the skeletal mesh - why the calves stick out.

I just got a message from Reallusion’s tech support saying that it’s a problem with the exported displacement map and suggested that I mess around with the settings in UE to fix it. I was able to get the surface to look more or less correct by dialing back the amount of displacement from 1.0 (the exported amount) to 0.05 - I say more or less because by doing this I’m losing all the Zbrush sculpting that I baked into the maps. The textures look and work great in CC3 and iClone, so it’s kind of disappointing. I hope that Reallusion will fix this export issue at their end and not merely think this workaround is acceptable.

I think their remove hidden mesh during export is kinda faulty as well. I can see boobs when i turn the opacity down for the bra.