Casting same child fails sometimes

I am working on a blueprint script to generate a series of rooms by spawning children of the Platform_MASTER class.
Here is my blueprint:

The array of my platforms contains only 1 item, which is the child of Platform_MASTER.
When this is run, sometimes it will generate many in a row, sometimes it will only generate 1 or 2 before saying could not cast to Platform_MASTER (print statement).
I have tried to use the do once to slow the machine down and wait until one item finishes, and it has solved other bugs.

When I run:
First time:

Second time:

Note: the words behind my print statement is just the rebuild lighting message

the first thing i would try is to replace the length node (after level groups variable) with a last index node. you say the array contains one item which would be index 0, but with one item the array length is 1. so you could be trying to get index 1 which doesnt exist. with the last index node and one item in the array it will only return up to 0.

yep, it was a silly mistake of not decrementing the length, I guess there is no index out of bounds error with these