Cast to actor in content browser fails

I’m trying to cast to the actor I’ve selected in my content browser (GrassyTile_BP), and then set the actor’s map based on what’s in my designated file directory!

So far everything’s went pretty well, but when I try to cast to my blueprint; it fails. When I print string for what’s being found from my selected assets node; it has my blueprint’s name (GrassyTile_BP).

Is there a different way I’m supposed to be casting in order to change my actor’s map?

The reason why I’m doing this just incase there’s a different approach I should do:
Currently each map holds 48 static mesh object references, and I have 9 maps I need to prefill; so I’m looking to save some time by automatically registering each reference, and also make this more easily expandable. (Right now I have to manually add each object reference. Super time consuming!)

That was definitely what it was! Now it’s able to find it, but it’s still unable to update the blueprint’s defaults unfortunately, and I’m not too sure how else to go about it. Currently my first guess is something like a struct, but I’m not too sure if those can be accessed from utility blueprints either; so if you happen to have a better suggestion it’d be much appreciated!

Same problem.

  1. You can’t get actors of class, because there are none.

  2. You can change the defaults, because you don’t have an instance.


This will probably be not much help, but I assume it’s failing because you don’t actually have an instance of that asset?

Maybe you can compare the class of the asset or something…

I’ve solved it! Moving the core of the script (Changing my map’s object references automatically) into my tile’s blueprint on an event that gets called by my editor utility widget did the trick! Putting it in the construction script also worked just fine, but I didn’t like it getting called every time the construction script ran.