Car Wheels SINK into terrain and wont move forward

I have been trying to run a rigged car from Blender using the very basic WheeledVehicle blueprint component, the rig is perfect, and simulates pefectly in the Physics asset editor just like the default UE4 sedan vehicle. However, when I hit play the vehicles wheels legit sink into the terrain (or any other 3d mesh) , the wheels are simulating and turning perfectly but the car wont even move forward or back.

I have seen multiple other comments on youtube tutorials facing the same/similar issue, I have tried following their steps of fixing it but none of them have worked as yet.

Here are all the steps I have implemented -

  1. Imported a car from Blender using centimeters, All the wheels are parented to the body accordingly
  2. Exported as fbx ( -x forward, z up)
  3. Imported as skeletal mesh
  4. Duplicated the default ue4 blue sedan and replaced the mesh with my new skeletal car mesh, and replaced all the
    wheel configs with new wheels
  5. Created Car anim instance BP, VehicleWheelBP, New GameMode, Even changed the tire radius etc etc (
    basically followed youtube tutorials)

If you enter “showdebug vehicle” in the console, the engine will render the actual physx wheels. This might help you find out what’s wrong. If they are spawned, but at the wrong location, I’d suggest to make sure that the root bone transform is set to identity. UE4 has (had?) a bug that caused vehicles to fail if the root bone transform is not identity.

Check if your wheelsize is set to the correct size according to your mesh.

Your radius of your Unreal wheel assets should fit the size of the mesh

Do you mean the radius of my mesh size or the whole wheel size?

How do i see “showdebugvehicle” in the “console”?

just type it in there, then it will be recommended. Just open the console when you are playing in the editor

:smiley: no you need to open the console in the “game” :smiley:
On default you need to hit the “^” key I think. I have set mine to an other key. then you play your game and press the right button. Then there will be a textline where you can type in different commands such as statFPS or something. THERE you need to write showdebug vehicle in. Then it should work

I went to project settings > console > typed “showdebug vehicle”, nothing appears, anything that i need to enable?

You can also use the output log window, which has a console line at the bottom. As said, if you have the vehicle possessed, and input this, you should get debug output. Vehicles: Top Speed & Acceleration | 02 | v4.2 Tutorial Series | Unreal Engine - YouTube

I have the same problem and the above answer doesn’t fix it.

The solution is to open the file in 3D Studio format with 3DMax. Once there, you must create the bones for each element (FLWheel, FRWheel, RLWheel, RRWheel, FLBreak, FRBreak, FRBreak, RLBreak, RRBreak, SteeringWheel, etc.). (as many elements as you want to appear in motion, as doors)). You have to make sure that all the elements of the car have the orientation of Z upwards and X forwards. It is also important that you work with the units of measurement in centimeters CM, and that the car measures between 600 and 610 cm long. Once we have linked the elements of the car to each bone, we export the file in FBX format to UnrealEngine. After that comes much more… but the basic thing for the model to work and not sink into the ground is this. If you have any questions you can contact me at jaimerevertebrotons@gmail.com

What is the problem in question?

^did not fix the issue, anyone know how to fix this?