Car does not move in v 4.18


I tried everything, I have been following hundreeds of tutorials

the car does not move AT ALL

please take the time to check the attachement and check the issue

the only thing I found missing was the game mode, but I added one an referenced it in the porject settings it does not work

also the bones where wrongly referenced in the blueprint, but even fixing that, I still cant make it work

best regards

link text

I am checking this out

is anyone gonna reply this thread ?

I finaly (after one week) kind of figured it out,

although my wheels were 14 units ray, I ended up with 0.7 physical spheres

it seems I have to set cm in blenders so things get imported right

but I tried to create a second vehicle , removing one wheel, and now it sinks in the ground

I tried PXVIS COLLISION too, as a wild guess, it seems the ray casting algo of Wheeled Vehicle class does not see the ground

here is the attached projectlink text

so after digging a bit, it appears that if I use less than 4 wheels with the WheeledVehicle Class, it simply stops working, so I guess I’d have to start programming my own vehicle class, which I wanted to avoid

[edit : I managed to have a 3 wheeler, by giving twice the same wheel in the WheeledVehicle BP]

Hello, could you please explain how you got it to work with a 3 wheeler? I’m facing the same problem

bump: are you sure it’s doing the same wheel twice for a 3 wheeler?