Capture Component 2D doesn't use relative draw distance when in orthographic projection type

Hey guys. I wasn’t too sure where to put this, but I ran into something that’s a bit strange, and I don’t know if it’s a bug, or if it’s by design.

I am using a ‘Scene Capture 2D’ component to capture terrain interactions, but I discovered that when you use the projection type “Perspective”, everything appears to work correctly, and from the relative distance of the camera. So if you set an assets max draw distance to lets say 250, and move the asset in front of the camera, it works as long as it’s within range, and when you pull it out of range (more than 250 units away from a surface), it dissapears. This all works as it should.

However! When you change this to use ‘orthographic’ mode, things work differently. Instead of the distance being rendered from the cameras location to the asset, it is locked to the 0,0,0 location of the scene. (Here’s a few photos to better explain what I ran into).

This is the very basic setup I have. A material that’s on the floor that references a texture.

This is the settings I have for the camera. The texture is referenced. The draw distance is set to 250, but in this case, it actually doesn’t matter. That only seems to work for Perspective.

And the basic scene is like this. The plane on the ground (the black) is referencing the material so I can get a visual representation of things. The selected flattened square is 240 units above the camera, and the camera is set to a height of 100 units. This would make the selected asset only 140 units above the camera, well within range. But if you move it above 250 when the camera is set to ‘orthographic’, then the asset will disappear, but if you change it to ‘perspective’, it will work correctly.

Here, you can see that once the asset hits a height of 250, it no longer renders. The implications of this is, if you have assets with draw distances set manually, then if you’re further than that distance from the origins of the map (0,0,0), then the asset won’t render, regardless of where the ‘Scene Capture 2D’ component is.

Strangly enough, the same thing happens in reverse, but in reverse, and with clamped values. So, in this next image, I pulled the camera to a distance of -500 in the height, and the plane is at -200.

And finally here, you can see that as long as the flattened square is within the distance of 250 units from 0,0,0, it renders, but the moment it dips below -250 in the Z axis, it no longer renders that, but still renders the X I placed at 0,0,0.

Moving the Scene Capture 2D component around still updates correctly in the X and Y axis when using Orthographic view, but the Z axis seems to be locked to the worlds Z location instead of the cameras. To me, this doesn’t seem right.

(Sorry for the long post and all the photos, and sorry if it’s in the wrong location, but if this is a bug, I can see it causing headaches for more people than just myself and was wondering if anyone else encountered this)

Testing on 4.25 ]

  • Kind Regards
1 Like

Did you ever get around this?
I’m so glad I found your post. I’ve had related issues where the orthographic render of my scene will start pixelating more and more the further away I am from world origin.

Obviously my render distance is far enough.

I’m now considering using perspective mode, but use a narrow field of view tele-lens to capture the scene from a distance - which will make it render nearly orthographic.