CapsuleComponent collision when moving

I’m creating spider with custom movement and I have a problem.

Spider is colliding/blocking with other Characters - for example my player as well. He is so small and should have disabled collision with everything but still I want to move him using Behavior Tree. When I disable Collision he goes below ground and wont’ move.

Anyone know how to disable CapsuleComponent collision with other Characters? (just create bp from Character you will get this component)

Select your Capsule component. In its properties, there is a section called "collision’ where you can have custom response based on Collsion channels. For ‘Pawn’ channel, make sure you select ‘Overlap’ (instead of Block)

Did that - still colliding.

Check your mesh, does it have any collision volumes of its own?
Also can I see the collision settings + component hierarchy for your Spider?

Nope, I’ve disabled all collisions from the Mesh. the only collision that I can see in-game is Capsule Component and I can see that Player Capsule Component is colliding with this Capsule, not with triggers or something else.

Here’s screen. Really it’s easy to reproduce just create a character place it on the level, Move him using BehaviorTree or Navmesh and see that Player will collide with it.

If you are not using the Behaviour tree, does he still collide with your character? Just try to move him without the navmesh (like use SetActorLocation with sweep) and see what happens

Yes - still colliding. Just placed spider into the level without any movement and AIController and it’s still colliding.

Looks like you are right. I tried to replicate your condition, and I am also experiencing the same issue. The only way I was able to make it work was to set the collision response to ‘Pawn channel’ to Ignore or Overlap in both blueprints (ie Spider and the Character). When both ignored each other, it worked. But this does not sound good. When I tried with a blueprint derived from an Actor, it all worked perfectly.

I will play around with the configs and see if I can find anything.

Glad im not the only one. I have tried everything. Thanks!

So it looks like this happens only when both actors are derived from Character, right? I made the spider a bluepribt extended fron Actor class and things worked as expected

Same here. They need to be Character with movement.

Can someone from Epic comment this? I think it’s a bug.

#Going On Since Beta

I have experienced this issue as well

I have never succeeded in getting Characters to not collide with each other, but still have the character collide with Static and Dynamic World Geometry

#My Goal

I wanted to make a Mech that smaller characters could walk underneath

#Solution

My solution was to make the collision capsule extremely small, about 3 units wide and tall

This actually works out great.

Here’s a video of my result:

Notice how the character can be walked over by the mech, yet the mech does not fall through the terrain

:slight_smile:

#Ideal Solution, Epic? Please?

It’d be great if we could have character capsules that did not collide with each other but could still collide with terrain!!!

Reported a bug here:
https://answers.unrealengine.com/questions/77520/collision-channel-settings-does-not-work-when-both.html

Hi everyone,

We’re going to continue this as a bug investigation in the post that Mindfane has created.

https://answers.unrealengine.com/questions/77520/collision-channel-settings-does-not-work-when-both.html

Please forward your responses and information to that post. I have assigned a technician to investigate the issue and reproduce it for a report.

Thank you,

Alexander

There appears to be a minor bug in how this is supposed to react. Normally if one actor is set ignore a type, they should simply ignore each other. However,I just got it to work by having each Capsule Component set to ignore the other type. For example:

  • Setting the Collision Presets to Custom then…
  • Spider is set to be of Object Type Vehicle and ignores Pawn.
  • Character is set to Object Type Pawn and ignores Vehicle.

I’d advise creating a custom Object Response in Project Settings → Collision → Object Channels, just so you have something that is easily re-usable.

(tested in 4.4)