Capsule trace fails

So, I opened my 4.13.2 project in 4.14.1 to discover capsule trace failing on my mesh-based terrain. The whole setup is simple - trace, get a hit, place arrow actor at the hit location. Arrow actor as no collisions.

Here are the videos showing the issue:

4.13.2 (no issues):

4.14.1 (trace fails at times):

There is absolutely no difference between the projects.

I can provide my project to test with, privately, when Epic gets on this case.

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/settings that may be involved with this issue?

I can try, but I’d still have import all the BPs and terrain mesh from my project, so I am not sure if it will do any good.

I’ll post screens of the tracing part of my first person character BP.

It’s just really a basic capsule trace by channel with custom channel. It worked since 4.9 to 4.13.2 and now fails in

Here is my tracing setup:

Full image: Google Drive: Sign-in

Note that I added box trace and line trace nodes (and I tried sphere trace before that too). Those work without a hitch. Capsule traces falls through some polygons on the terrain mesh.

Basically that actor-arrow casts to player, gets that playerPhaseLoc variable and sets world location of the default scene root component to that value. So if the trace hit falls through, arrow won’t be sitting on the face of the mesh obviously. And since all other types of traces work, there is definitely an issue with capsule trace by channel in particular.

I am unable to reproduce this issue with the information provided. Could you provide a zipped copy of the project that is having the issue so that I could take a closer look?

At work right now, but will do it after I get off. Can I share the link via PM on UE4 forums with you? (or however else, privately)

Sent you a PM (UE4 Forums) with a link to the project.

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: Unreal Engine Issues and Bug Tracker (UE-39989)

Make it a great day

Hmm… I am getting “Unknown Issue” following the link :confused:

The link works now.

The terrain seems to be the only thing that fails to hit the trace. You could probably update the vote by replacing ‘static mesh’ by terrain (unless some people are having issues with other static meshes?).

I don’t have terrain made using “terrain”. My terrain is made of static meshes.

Btw, I’ve been using sphere instead of capsule and it seems it suffers the same issue (just not was badly as capsule trace).

Just tested 4.16.1 to see if the issue was fixed and … it’s still there o.O

I retested the issue on our end and it appears that this issue is still happening. I have reopened the issue.

Make it a great day

Tried complex? For me tracing has… issues without it. Basically location does not return the last “not-overlapping” location, instead it returns one where overlap is present. If I tick complex it works as if it was a sweep.
Location does say it only return the last good location if sweeping but since you cannot tick in “sweep” anywhere that note is half useless :slight_smile: