Canvas problem

So when ever I move the camera the Canvas goes out of place from the top left area, Why?

Hello LeasterBeaster,

Could you explain what you mean? Which camera are you talking about and which Canvas? Is this happening inside of the Blueprint Editor for your Widget, in the Level Editor Viewport, during PIE, etc.? Screenshots could be helpful to explain what the problem is.

So when I move the camera the whole canvas from the UI moves to the left and see some artifacts and when I tried to take a screenshot (when my cursor shows) it goes back in place, but when I go back it does it again.


I see the issue in your picture, but are there any special properties of this widget blueprint that affect the camera or cover the viewport with anything? I tried adding a basic widget blueprint with a progress bar like your health bar and making it appear, but everything seems to work fine. Have you tried making a blank widget blueprint and substituting it in for your existing one temporarily to see if it make a difference?

That would be great. The more information you can provide, the easier it’ll be for me to find the issue.

No. But I could rework the blueprint or show you how it probably effects it?

Got it fixed sorry… it was the game over screen from a vertical box…

wait maybe not…

Here let me show how it works

So yeah

One more


To clarify, does this only occur when both widgets are on screen? Is it only a certain one of them causing the problem? Does it look normal if no widgets are on the screen? When you mention moving the camera, do you mean moving it as in turning your camera as the First Person Blueprint character?

It happens when just the health is displayed, I’m wondering what could cause this myself.

Well I think it just might be a graphical error, Because I put it in a separate window it does not do it… odd

Hello LeasterBeaster,

I’ve yet to see a reproduction of this problem so there isn’t much I can do at the moment. Is this issue fixed for you or have you made any progress as to what may be causing it?

No, but I did print strings what might cause it. But sadly still nothing.

But I made a blank widget and see what would happen without the code for health and what not, it still does the same thing…

Is it because of the EventBeginPlay?

I’m not sure, I haven’t seen what you’re doing with EventBeginPlay so I cannot tell if that would be a problem or not.