Can't use SVN


I tried to connect to my SVN by using the integrated plugin. But how do I start my project on my SVN for the first time in Unreal Engine? When I try to submit all I get is an error message like this:image? But when I enter all my info when connecting the first time it goes perfectly well and says it has connected succesfully.

This might be the easiest thing to do, but im going crazy over this.

I’m currently using UberSVN with Subversion 1.7.9 Binaries on a remote machine that is working perfectly well on other reps using Tortoise.

Please help!


Hi Sparven,

Is this a subversion server running locally, or remotely somewhere? Can you give me a general idea of what the configuration looks like. feel free to mask out the identifying stuff.

Nick (Epic Games)

It a remote server running Windows with UberSVN running on it. (Link
It’s running the Subversion 1.7.9 Binaries on it with multiple reps working already with Tortoise on the remote clients using it.

This rep is new and shining just created, I have tried both with trunk/branches etc. in there and without. Same result in all tries. The strange thing is that I do get a connected succesfully even though I can’t do anything after that.

Every user has full rights right now until I solve this problem aswell, so it can’t be there either.

Is there a crash course in SVN for Unreal Engine anywhere yet?

Here is a few pics showing the status and “succesfully connected” message.

Hi Sparven,

This is a known issue. The SVN binaries the editor uses for its operations accidentally didn’t get shipped with the Launcher version of the editor (GitHub users should not be affected), so it is currently unable to interact with Subversion.

If you want to use SVN with the Launcher version, you can work around it with the steps below. Fair warning, though: this is not an officially supported workflow, so use at your own risk.

  1. Go to and download the Apache Subversion command line tools.
  2. Open the zip file and go into the “bin” folder.
  3. Open Windows Explorer to your engine installation path’s …\Engine\Binaries\ThirdParty\ folder (default would be C:\Program Files\Unreal Engine\4.0\Engine\Binaries\ThirdParty).
  4. In ThirdParty, create a folder named “svn” (no quotes).
  5. In “svn”, create a folder named “Win64” (also no quotes).
  6. Extract all of the EXE and DLL files from the zip file’s “bin” folder into “…\svn\Win64”
  7. Start up the editor and enjoy using SVN.

Thanks! I’ll have a look at you solution then. Hope it get fixed asap so we have a more stable version going soon!

Are you kidding me :V

This was an issue on the last beta build as well. How did the Binaries still not get included??