Download

Can't use Epic Visual Studio

I’ve tried starting a project in Epic for over a month now, but no matter what it tells me that I don’t have a compiler installed.
I’ve tried the following.

  1. I already had visual studio installed before hand, because I use it.
  2. Uninstalled and reinstalled with the Epic option (whatever it is called C++).
  3. Tried installing from the link in Epic itself, but it just complains that packages aren’t found and fails every time - 0 of 200 something packages install successfully.
    At this point, I’m open to suggestions, but it sounds like Epic just doesn’t know how to figure out if you have a compiler installed or not.

H1 @Ashenshards ,

You’ve probably already seen the page:
https://docs.unrealengine.com/4.26/en-US/ProductionPipelines/DevelopmentSetup/VisualStudioSetup/

If it still doesn’t work could you post the error message/log file ( in project/Saved/Logs/*.log ) ?

1 Like

I highly recommend this video: Unreal Engine C++ Project Setup, From Scratch

2 Likes

I had to get a tool called total uninstall to completely clean out visual studio, once I had done that I reinstalled visual studio 15 and now it works.

1 Like