Download

Can't update to 4.7.5

Hello
I’ve tried to update to 4.7.5 but it’s always getting stuck on 89%. I tried to reinstall whole 4.7 engine and redownload, but still getting freeze at 89% =/

Hi,
I’m having the exact same issue.
Mine’s now stuck at 90% (that last 1% took >1 hour).
I can still open the engine from a shortcut and it appears to load 4.7.5 just fine, but the launcher’s stuck in limbo.
Going to reboot and see what happens.

Had to reboot twice but I’m good now.
Loads of this in the Launcher’s log:

I have the same issue.

Same issue. If I can’t update is there a way to roll back to the previous version, like 4.7.3?

Mine was stuck at 90% verifying for about 45 minutes … but eventually moved on and finished successfully. I did not have to reboot or intervene at all. I basically let it run and watched some TV.

It finally finished for me as well, though it took about an hour and a half after it froze the first time and I had to re-download. Next time I will update overnight I think.

Huh, I was sure it was issue with my PC o.o
It succeed without freezes after full reinstall of Launcher and 4.7.5

This consistently happens with every update. Where sometimes it gets stuck. Usually I have to delete it reboot the PC and re-download. It hasn’t happened to me since the last two updates, but it did happen quite frequently, and clearly still happens now.

This should probably be looked into.

Hi everyone,

Can you please make a post on the answerhub about this in the installation and setup section so we can assist you more in depth? Thank you!