Can't update/install version 4.10.2/4.11 R-1638

I have Windows 10 pro x64, updated and tried to follow the footsteps of the removal of the “redistributables-> vc ++ 2015,” but nothing works.

I searched

Hello Drakgoku,

Are you only having problems updating to one of the 4.10 hotfixes or are you also having issues installing 4.11 Preview? In the case of the former, there is a bug already in our system for this and another user has been able to find a workaround for the issue that involves removing the UE4 prerequisites from the 4.11 Preview install.

You can find it in the comments on the accepted answer.

Why resolve my post ? not work, I uninstalled all and not work :wink:

When staff members leave answers, they’re automatically resolved for tracking purposes so that we know when you leave a response.

You’ve stated that you’ve removed the VS C++ 2015 redistributables but what did you uninstall exactly? Uninstalling the 4.11 engine will not remove the prerequisites. You’ll need to navigate to the 4.11 engine’s installation directory and uninstall them directly.

They can be found at C:\Program Files\Epic Games\4.11\Engine\Extras\Redist\en-us if you’re using the default installation location. If you run the UE4PrereqSetup_x64.exe and choose Uninstall it should remove them.

If you have uninstalled 4.11 already, you may need to reinstall it for this file to be available.

I tried 5 times :wink: (I love destroy register from windows!)

I uninstall V10 v11 also and uninstall VS 2015 C ++ X32 / 64.
then I uninstalled the “Unreal Engine”
I searched in c: / “everything related to unreal” removed
And it so happens that does not work;) I’ve only tried it on my Windows 10 pro

Unreal engine need fix this error

Please try following these steps and let me know what the results are:

  1. Reinstall 4.11 Preview through the Epic Games Launcher
  2. Navigate to 4.11’s installation location (C:\Program Files\Epic Games\4.11 by default) and then find the UE4PrereqSetup_x64.exe file (should be located under Engine\Extras\Redist\en-us)
  3. Run the UE4PrereqSetup_x64.exe file and select the “Uninstall” option.
  4. Once that completes, try to install 4.10.2 through the Epic Games Launcher.

I get error :

This is log :
link text

You’re running the UE4PrereqSetup_x64.exe inside of your 4.10 installation folder, not the 4.11. You need to run the one in the 4.11 installation directory to uninstall it and then attempt updating 4.10.

pfff so really nice, awesome… @ you save my day and my hours ;), Can you tell me why engine detect only last prerequisites and not the normal ?

I don’t understand what you mean. The current bug that is causing this is due to the 4.11 prerequisites being installed when the launcher tries to install the 4.10.1 or 4.10.2 prerequisites. Instead of installing them separately, it tries to install over the 4.11 ones but cannot due to it being a newer version.

I lost 1-2 days on this issue! THANK YOU!