Download

Can't unlock FPS

I’m trying to do some performance optimizations, so I want to unlock the FPS limit of 62.

I’ve tried setting bSmoothFrameRate=TRUE in UDKEngine.ini, but the engine still doesn’t exceed 60.

Does anyone know why this isn’t working?

So you tried these too???..

MinSmoothedFrameRate=30
MaxSmoothedFrameRate=120
MinDesiredFrameRate=60

you have to be using dx11 I believe for it to work.

dx9 will work fine as well

what franktech suggest should be good. aside from that make sure VSync is disabled

Thanks guys. @franktech’s suggestion worked. Cheers.

Ummm, sorry to drag this old thread up. I just tried to unlock the fps again to do some performance optimizations and am finding i’m unable to unlock beyond 60, even with the solution that seemed to work months ago.

I’m setting MaxSmoothedFrameRate=120 in UDKEngine.ini

But everytime I enter the game it’s locked at 60. Anyone have any suggestions.

Seems that you have vsync enabled, as Chosker said.

Try in console “Scale Set UseVsync true/false”. Probably you need to restart the game (or change resolution) to take effect.

also you can use this in a exec function to change the fps limit on the fly: class’Engine’.static.GetEngine().MaxSmoothedFrameRate = value

Thanks @CobaltUDK. Using "Scale Set UseVsync false (and then restarting the game) solved the issue. I’m a little confused why using vsync would prevent th fps exceeding 60…

Because Vsync syncronizes the game with the monitor refresh, that usually are 60 Hz. That makes the game to run smooth, without tearing ( Screen tearing - Wikipedia ).

Give to the game more fps than the monitor refresh is not useful, as you never see the extra fps. In my game I usually set the fps to 62 (or 30 to no heat the machine) without Vsync, so I can change the framerate to higher values to test the performance.

For the final game, for the players, the ideal is 60 fps with Vsync.