Download

Can't understand how to make Bloom work effectively

I’ve been scratching my head about this for a few days now, and I can’t really figure out how mobile bloom works (or maybe bloom in general).

The way I believe it works:

Color values over 1.0, will contribute to a bloom effect.

How it is actually working for me:

If I actually set any Sprite Color in Paper2d over 1.0, it doesn’t seem to glow at all. After a lot of suffering, I was able to achieve a glow by setting the Bloom intensity to 1000. Reading the description of Intensity has me believe it just multiplies that value by the color value, so I figured if I set the Intensity back to one, and set my color values to 1000, I should get a similar affect but I don’t, no bloom at all. So 1000 wouldn’t be a problem BUT now my particles bloom’s are so big they take the entire screen up. Which is enough weird point, because with particles, I only need to get a little past 1, and things start blooming, but with Sprites, I needed to set everything up with outrageous intensities. I also tried messing with the ‘threshold’, setting it to 0.5 seemed to do better, which makes me wonder if I can actually even set Sprite values above 1.0 (maybe they are being capped?)

Is there something I’m missing here? Or is there a possible bug? Has anyone tried to get bloom working with Sprites in Paper2d?

Please someone save my sanity!

What’s your target/test device? In your Project Settings->Rendering do you have Mobile HDR on?

iPhone 6 plus, targeting IOS ES2 max quality, bloom is enabled in device profile HDR is definitely on. For now setting my threshold to .8 is doing nicely but I just don’t know or understand why it’s necessary to get my paper2d sprite colors to bloom.

You might need to increase your bloom intensity significantly under your post process volume.
Bloom on Ios hardly shows up with default values.
You need to increase it a lot

Keep in mind. That in the editor bloom will look ridiculous. But once you launch it on mobile it will look better. Its a bit of a hassle because of the huge difference in bloom between the preview and on device… but yes.

Bloom intensity set at 1 works fine for me on the iOS. I use it for glowing materials. I see the same thing in the editor as I do on an iOS device but I’ve never done anything with sprites.

Interesting. What version of UE4 are you using?
I have to set my bloom intensity to 6 to get it to show up on mobile.

The main issue for me now is increasing bloom intensity makes particles go crazy on bloom. It seems their sensitivity is much higher than sprites. My temp solution was dropping threshold to .8 with 6 intensity it’s worked nicely on mobile . But I really don’t think I should have to set the threshold to below 1 I think sprites are doing something different.

It has been the same since I started using 4.3 and I’m using 4.5. Since you can multiply the value connected to the emissive color by more to get the same affect as increasing the bloom intensity, maybe I’m just using higher value there. I’m not sure why the bloom looks different in the editor as it does iOS for you though.

Cool stuff.

After i increased my bloom intensity a lot of things looked blown out of proportion.
To combat this i had to darken all my textures where the bloom was too crazy. Some of my particles i had to adjust the materials and textures so the bloom would not go crazy there.

But unfortunetly for me there was no other way. I needed a strong bloom on mobile and unlike you my bloom would only work on extreme intensity settings.
I guess i could have gone the other route but i needed to keep my materials to only use diffuse and nothing else.

So i couldnt use emissive, therfor had to increase bloom and alter some texture maps etc.
Wish i could help…