Can't translate any objects in editor

When I select an object in editor and click and drag the translation arrows, the object doesn’t move. However, when I type in new coordinate location in the Details menu, it properly moves the object. The rotate and scale tools still work in editor - it’s just the translate tool that is not working. It was working and then suddenly stopped as I was doing level building.

Any ideas how to fix this?

1 Like

Problem solved. My grid snap value was set to 5000! You can see it in the top right corner of the gif. Yes, it took me over an hour to figure this out while working on other things.

1 Like

I’m having this exact problem except I also cant rotate or resize objects. The only way I can manipulate their position and size is to manually enter their coordinates. My snap is set to 1 for translate. 0.25 for resize. and 10 degrees for rotation. I can access all of the tools and the arrows show up when I click on an object but when I try to actually move it nothing happens. I should also add that this only happened after I accidentally clicked on build (not sure if that has anything to do with it).

I’m having the exact same problem but my snap is set to 1 (even when I disable snapping it still doesn’t move)

I had the same problem. I tried snap, but that didn’t fix it; I even closed the editor and started over with a new project, but the UI setting was persistent.

I changed the ‘camera speed’ and suddenly the arrows showed up.

My guess is … changing one of the UI items causes the UI system to regenerate or something. It’s probably random which one is touched.

    == John ==