Download

Can't submit product to Unreal Marketplace?

Whenever I try to submit my product it just loads for a few seconds and does nothing. Help? (Product won’t save in drafts either)
(I don’t know if this is the right place to ask this sorry)

Hi, try another browser. That will help.

Thanks so much! Seems that it doesn’t work on Firefox but does work on Edge and Chrome :0

Having the same issue today. I’ve pretty much tried every browser there is.

is it solved?

No I just tried again this morning. It remembers all my info but I can’t get past the part where you open the portal. I submitted a support request but looks like Epic is closed until July 8th…

The Marketplace team is still working, although at a reduced capacity. We weren’t able to repro your report from the info shared here, but a team member is going to contact you through your support ticket to get more info.

Thanks,
Josh

Thanks Josh. I wrote them back, but I’m still not able to get past open shop page: Publisher Portal. All my info is still saved but I can’t go any further. I made video showing what’s happening: https://www.youtube.com/watch?v=OKNo…ature=youtu.be

Hi @MarkcusD, Try Opera browser. Its free. Ctrl+F5 on the shop page you presented is a great thing to clear the cache, try this.
As an option you can try open the “Private tab” in your present browser.
Think that will help.

I tried Opera and private in chrome and Opera. Still a no go. I’m thinking my account data must be corrupt somehow. It won’t let me erase everything and start over which is what I would like to try.

Epic helped me out :slight_smile:

I am having the exact same problem today in chrome, firefox, and edge

I’m having the exact same problem today as well. This is so ■■■■ frustrating. I submitted a support ticket so hopefully Epic gets back to me.

Same ■■■■ here too …