Can't start Unreal Engine 5 on Ubuntu - Vulkan Error

I am trying to launch Unreal Engine 5 on Ubuntu 22
The message I receive is: Cannot find a compatible Vulkan Device.

On my terminal I can run vkcube to see a cube from Vulkan.

Is there someway to configure Unreal Engine 5 on launch time to fix this problem?

same situation here with UE 5.2.
Did you solve this?

I am having same issue of UE 5.2 crashing on Linux. I am getting a few errors although the cube worked and I did get this: uid@machinename:~/UnrealEngine/Engine/Binaries/Linux$ vkcube
MESA-INTEL: warning: Haswell Vulkan support is incomplete
uid@machinename:~/UnrealEngine/Engine/Binaries/Linux$
Hope this sheds some light.

Don’t know if anyone else has encountered this.

Spent a few hours trying to figure this out, Googling around. Tried all sorts of things, like installing a command line Nvidia driver, manually installing and configuring kernels, etc.

What ended up working, was to install the linux kernel headers from apt and then rebooting.

sudo apt install linux-headers-$(uname -r)

Hope this helps!

1 Like