Download

Can't set "Simulate Physics"

Just learning here, playing around with different things. I decided to learn about setting up my T.flight Hotas and so I built a little space ship using the Geometry brush tools. Once the ship was complete, I turned the whole mess into a static mesh. Now I can’t use it as my space ship because I can’t turn on “Simulate Physics.” That option is greyed out.

I thought, well maybe that has to be set in a blueprint, so I created a blueprint, added my SM, but still greyed out.

What do I need to do here?

Thanks

does the static mesh have any collision setup?

Yes, In my StatiMesh I have

Collision Presets → Custom
Collision Enabled → Collision Enabled (Query and Physics)
Object Type → Pawn
Collision responses are all set to block
Collision Complexity → Simple and Complex

I’ve played with changing them around to see what would happen, but so far no changes have produced any change in the ability to enable physics

Thanks

no not that. go click on the collision tab up in the left corner and if the remove collision option is grey out, that means it doesnt have any collision and u need to generate new one

2 Likes

Much appreciate!!!