Can't Set Default Value in variable

When i try to set the default value of itemBP here: http://puu.sh/dJ6tu/bccdb7b6d2.png

Clicking it does nothing and leaves it as None.

Can you describe the problem? A

I have a masterConsumableItem blueprint which is an actor, and I make children of it for each item.

Inside these blueprints is an itemMasterStruct variable ThisItem which contains info about the item. When i add a variable to itemMasterStruct of a reference to masterConsumableItem, it does not let me actually set a value for it.

Hi Xendran,

At the bottom of your “My Blueprint” pane should be a checkbox that says “show inherited variables”. Select that to be able to access your variable. You should be able to adjust the values in your child blueprint without affecting your master blueprint here.

Check the screenshot, i have that checked. All the other variables inside the struct variable work.

When i place it on the map it appears to be initially set, but upon playing a failed cast shows otherwise (as does the editor after exiting PiE).

If i then try to set the itemBP, it resets all of the values inside of thisItem http://puu.sh/dKwJ5/9eb25b53d5.png

I also believe this is the culprit of a crashing issue i had before.

Is this a variable that takes in an already spawned actor? Try placing this Blueprint in the scene and access the Variable over the Property Window at the right side of UE4. There you should be able to assign something to this variable.

EDIT: Here are some pictures of what i mean. Made a test Struct with an Actor Reference:

http://puu.sh/dKw1L/e75967108c.png

I can’t set the Actor in the Blueprint default at the bottom. So i dragged it into the scene (spawned it) and on the right sight i can fill the struct:

http://puu.sh/dKw4U/98a3685b1e.jpg

Does this help you?

I added 2 Screenshots. Make sure the Struct variable is marked as “Editable”

Hi Xendran,

Do you have a sample project that I can take a look at where this is occurring or reproduction steps that I can take to recreate this? I haven’t been able to reproduce this on my end.

Is there a way i can send it to you privately?

If you send me the link via PM on the forums I will gladly get it there.

Okay I’ve PMed you the link to the project with steps on what i did that caused the issue.

Hi Xendran,

The struct you mentioned in your pm is not located within the project. Can you send me a copy of your struct .uasset and let me know what file it belonged in so I can get everything together? Or let me know what all is needed within the struct so I can recreate it on my end. Thank you!

It’s in Content > Blueprints > Inventory. Here’s a link to the struct uasset itself, inside the folder i linked you earlier: https://drive.google.com/file/d/0B6MprO-AJJ6jbnVRVWE4OGt4U2s/view?usp=sharing

Thank you Xendran, apparently that file didn’t transfer over when I pulled them. I’ll post here once I have a bit more information.

Hi Xendran,

Try creating a new version of your itemMasterStruct and see if replacing it fixes the error.

Tried that, caused this http://puu.sh/dTPBN/856a005fc5.png

Hi Xendran,

I have not been able to reproduce this on my end. Do you have any other steps that I can take to recreate the error you are seeing?

I’m having the same error. I can set everything else in struct exept the “item” (actor). Did you guys solve this?

Hi Frisco,

Are you attempting to populate the item with static meshes? Can you post a screenshot of what you have thus far?