Can't set character on gamemode

So I have been running into many problems with the new 4.8/4.8.1 updates. One of them is stopping me in my tracks. The gamemode I made is not letting me set a character or “the default pawn.” Every time I do, it just sets it to none. So I am really confused and frustrated by this. I hope this will be resolved. Thank you for your time!
Here’s an image for example.



Try to select the character in the content viewer and then click on the arrow at the right of the select combobox.
Also, did you build everything ? Because it may not display because the that.

I tried building everything and it still doesn’t work. Is there anyway you can explain a little bit more about right clicking to see the combo box. I don’t know what you mean (sorry). Could it be that my version is super buggy or like my computer. How about having a big map? I don’t know if that would make a difference. Thank you for helping. I hope you could solve my problem.


Here a screenshot will help :slight_smile:

Still have none, by the way it converts it all to none. So I don’t really think its the character. But it might be. Thanks for showing me a combo box though!

Before setting the character you need to set a GameMode :slight_smile: Then you will be able to set other component :smiley:

I`ll try that tomorrow, that might be it. I will give you my results then. Thanks!

So I tried it, I got the same results. I am going to try uninstall 4.8.1 and reinstall it, see if it makes any changes.

Ok, I uninstall the update and reinstall it. Something happens. But when I switch game modes to the default gamemode it was Rebuilding class Hierarchy and then crashed. Like this post you wrote on Engine crash when changing "gamemode override" - Platform & Builds - Unreal Engine Forums. So I tried what the said to do and still the same “none” bug thingy. I don’t think this could be fixed or find a work around. I do now the “none” bug happens when I choose mygamemode and with in the game mode it self I can’t seem to put my character in the gamemode combo box. This never happen to me before, ever. I am wonder why it’s happening now. Thank you for the help though. If you have any other ideas on how to solve this, PLEASE do comment. Thank you so much again for you time!


Fixed it, don’t name anything that contains (). For example Blueprint(s). It just messes with navigation of the assets. I don’t know why they gave me the option to do that but at least there’s a fix for it! Thank you again for the help!