Can't select value to edit variable in editor window.

I am running into an issue where, upon selecting a value for an editable blueprint variable in the details window of an instance in the editor, no value is selected. It appears to occur in all newly created BPs but not in BPs I created before today with exposed actor reference variables (they still seem to work).

I do this frequently and am familiar with the requirements (must be editable and public, etc.). Perhaps there is something I am missing, but I think I covered all my bases. In this case the drop down populates with actors that are viable for selection (see image). But upon clicking no value is updated.

I tested to see if this is just a UI glitch and it was just displaying “none” even though a value was set. This is not the case. The variable is not valid at run time.

I tested an older blueprint in the same project with an exposed actor reference (to the same class as this case in fact) and it worked fine.

I then created a new actor blueprint, added one actor reference variable, and exposed it to the editor. When I placed an instance of this new BP in the level I was able to reproduce the glitch and was not able to select any actor even thought the drop down was suggesting options to select.

I further tested this with multiple types of actor references (i.e. reference variables to various classes) with the same results.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


If you have recently created the variable, it cannot have its instance or default value changed until you compile the class that contains it for the first time after adding that variable to the class. This might be why you’re having this problem. All you need is to compile the class again after you added the new variable to it.

Yeah… Afraid that’s not it. (I double checked). I’m usually pretty prone to think that I’ve done something wrong long before I think I’ve found a bug… Definitely still that potential, but if it is something I’ve done I can’t figure it out for the life of me. It isn’t the default value I’m trying to update (see picture included) it is setting the variable on an instance. Afaict the instance variable doesn’t even show in the editor until its compiled.

Either way I compiled and saved it again and still have this issue.

I even tested adding another editable/exposed boolean variable, compiling, and editing that on the instance. That works, but I still can’t update the actor reference variable which was added first.

Yeah sounds like a bug. Hope you can get it resolved soon

For what it’s worth…

I just ran into this issue while setting up an event on a switch to activate a door; the (target) door blueprint instance would show in the switch blueprint’s variable drop-down, but I could not select it.

What ultimately fixed it: creating a new door instance and deleting the old one. The new door instance showed in the variable drop-down as well, and this time I could select it.