Download

Can't select translucent Paper2D Actors.

Hi I can’t select translucent actor/material although setting is activated. Any idea why?

I’m thankfull for every help.

I have multiple paper2d actors with translucent materials.

I made some more tests und it works with version 4.25.1 but not in 4.25.2. Is this a bug? where can i report this?

There is a shortcut key that toggles this, I don’t remember which one though so you’ll have to look it up lol

The shortcut key is “T”, for translucent.
Cheers

Yes i know. Still doesn’t work. Thats what I said in the first post.

I’m I the only one? Where could the problem be?

Edit: 3D Objects are selectable, but paper2d objects are not.

If someone as the time, it would be great if you could test this out:

  • Create a SideScrollerTemplate project
  • Select the Paper Character and edit it’s Blueprint
  • Change the sprite material to TranslucentUnlitSpriteMaterial (active Engine and Plugin content in the view options and search for it), save and close the Blueprint
  • Back in the Map try deselecting and selecting the PaperCharacter again

Selecting is not working on 4.25.2 and above

Effectively just tested that out, Translucent selection is broken for sprites post 4.25.2
That’s a bug

Yep same issue here. 4.25.3

I have had this for ages now. I use UE4 to teach games design and this is deal breaker for me! Please fix this Epic!

As a quick workaround for myself, in my BP for my translucent sprites, I added a Billboard component. By default it has a dragon’s head for actors, is always facing the viewport, is visible, and is hidden in game. Most importantly, I can click on it.

I am also facing the same problem in 4.25.4… any other solution?