Can't select an actor from dropdown list

So I’ve been trying to write a function that needs to use an actor that has already been placed in the world. I exposed this actor to blueprint using this code:

UPROPERTY(EditAnywhere, Category = "Path") 
APatrolPath* PatrolPath;

It shows a dropdown list and desired actor in blueprint but when I click that actor nothing happens.
I also tried to select the actor from the scene but also nothing changes. It keeps saying “None” whatever I do. Due to this I cannot really pick any object from the scene.



Here are some images illustrating my problem (i attached them in the comment because I was not able to attach them in the post, the uploading was stuck at 0%, i do not know why)
A I said, when I click the “BP_PatrolPath”, the “None” still remains

Well, I guess you could try making the variable BlueprintReadWrite as well.

I’m not sure why that would fix it, but it would turn everything “on” that you can possibly activate. Maybe it needs something from it.

Other than that, I don’t really see any other possible problem with the actor doing the selecting. Is there something that could be problematic from the selectable PatrolPath actor that could be causing an issue?

Thanks for the response,

Setting the variable as BlueprintReadWrite didn’t help.
I don’t see any other problems with the actor. But I noticed that I can select the actor while the game is running in the details panel.

Hello, I know this is too old but I have the same issue with you. Did you solve this issue?

I was having this same problem too (also a response to @uijin.lee ). There is a pretty quick and easy solution (Repeat on both the target blueprint and self blueprint):

  • Right click on actor
  • Hit “Asset Actions”
  • Click “Reload”
    This worked for me, and hopefully it will work for any others with this issue.