Download

Can't seem to figure out how to enable error coloring. Anyone know how?

I’m having a whole bunch of LightMap issues making the jump from UDK to UNREAL 4.
I keep getting errors with all the assets that I’ve created when importing the .FBX files in.
It’s an issue with Overlapping UV’s, due to me utilizing as much UV space by overlapping identical areas of a mesh on the same UV section.

This worked fine in UDK, but in UNREAL 4 causes wAcKy shadowing & artifacting all over the mesh.

I’m now re-UV mapping all my meshes (175-200) to make sure that there’s no overlapping.

BUT… sometimes I still get the error that there’s overlapping UV’s & the error is telling me to…
“enable error coloring to visualize”
but I have no idea where that option is lol

In general it is totally fine to have overlapping uv’s as long as they are not overlapping on the lightmap. Do you have a separate uv set for the lightmaps?

It took me forever to find it as well, i almost posted a question for it too. On the toolbar to the right of the Build button there is a drop down arrow for the build options menu. You should see a checkbox menu item called “Use Error Coloring”

It will highlight the error areas. In the default content of version 4.01 the Shape_Cone static mesh has these overlap errors. To see it in action, drop a Shap_Cone in your map, check the Use Error Coloring and build lightmaps. You’ll see colored orange splotches drawn on cone.

Nope lol.
I model in SILO 2 Pro and it only outputs 1 UV map.

Unless there’s a way to import a lightmap into Unreal 4, I’ll have to remake all my UV’s and most Textures.

THANK YOU TMEK!
I think it would be great to add a quick action function to the error message that would allow you to turn on the error coloring right from there, instead of making you hunt for the option.

If you can’t make two uv sets in Silo, you can let the UE4 handle it for you. Best thing for you might be to reuse the UVs from Channel 0 this way it just rearranges the UVs without distorting them.

I was having problems with my meshes and didn’t know what to do. Thx.

YES CHRIS!
You are the MAN!
Thanks for the diagram buddy.
Worked like a charm :wink:

Thanks for this! UE4 does a better job of automatically unwrapping and flattening UVs than 3dsMax does.

why I don’t have this menu? in version 4.5.0 I don’t understand can there somehow differently all this becomes?

http://s019.radikal.ru/i617/1410/4f/c79e05c30e27.jpg

why I don’t have this menu? in version 4.5.0 I don’t understand can there somehow differently all this becomes?

http://s019.radikal.ru/i617/1410/4f/c79e05c30e27.jpg

Check out the Details tab on the right. You’ll see a tick box to Generate Lightmap UVs. Enable it then hit Apply Changes, and it will create a second UV channel automatically. And apparently you already had it enabled during import so now you have lightmap UV’s.