Can't seem to add nDisplay to existing projects

I’ve been able to run the standard nDisplay tutorial and feel like I’ve got a decent grasp of the .cfg file setup. However, when I try to add an nDisplay to a pre-existing project, my project crashes when launched in the nDisplayLauncher. I’ve got both the nDisplay plugin and the settings adjusted, but it seems I’m having trouble with the concept of cluster nodes and assuming where the ndisplay is getting its camera information from. I’ve rebuilt the cluster node blueprint that existed in the tutorial, but nothing seems to be working. What am I doing wrong?

I’m getting used to seeing the following log:
Fatal error!

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x000000f8

0x00007fff21c7f0eb UE4Editor-DisplayCluster.dll!UnknownFunction []
0x00007fff21c7f001 UE4Editor-DisplayCluster.dll!UnknownFunction []
0x00007fff21c9aa41 UE4Editor-DisplayCluster.dll!UnknownFunction []
0x00007fff0ab022d2 UE4Editor-Engine.dll!UnknownFunction []
0x00007fff0a0e258d UE4Editor-Engine.dll!UnknownFunction []
0x00007ff6232f2e44 UE4Editor.exe!UnknownFunction []
0x00007ff62330b902 UE4Editor.exe!UnknownFunction []
0x00007ff62330bb5a UE4Editor.exe!UnknownFunction []
0x00007ff62331e31d UE4Editor.exe!UnknownFunction []
0x00007ff62332145a UE4Editor.exe!UnknownFunction []
0x00007fff83b97bd4 KERNEL32.DLL!UnknownFunction []
0x00007fff84a0ce51 ntdll.dll!UnknownFunction []

Following for help too

Getting fatal errors whenever launching an existing project with nDisplay as well. However, nDisplay works using UE’s default file as well as Ben Kidd’s tutorial files.

Having the same issue. Sometimes the error does not occur. Additionally, when running the same package on different machines, it might work on one but not the other.

Found out what causes the error. It turns out that nDisplay requires setting the window as fullscreen=“true” in the cfg file or setting the applications high DPI scaling override to Application.


Not exactly sure why the error happens int he first place, but you can reproduce it by setting the fullscreen mode to true, starting the app via nDisplay and then pressing Alt + Enter to leave fullscreen mode. The app should then crash with the same exception. However, I am not sure if this happens with high resoltuion displays only (4k monitor + Windows’s DPI scaling).

I was facing this issue. The way to fix this is to disable SteamVR and Oculus plugins on the project. That fixed it for me.

Disabling SteamVR solved the crash for me but still I’m getting only black screen after i Run the project.

Must be something to with the nDisplay config. Suggest trying out the UE4 nDisplay template and play with nDisplay settings.