Download

Can't see C++ function in BPs

I can’t have a much simpler function than this, but for some reason I can’t see it in my GenMobileGameMode class object in its BP… anyone know why? I’m not very experienced with C++ so might’ve missed something simple. I’ve tried building and rebuilding the code, restarted editor and some other less logical efforts.

GenMobileGameMode.h:

UFUNCTION(BlueprintCallable, Category = “Game”)
void Foo(bool bPause);

GenMobileGameMode.cpp:

void AGenMobileGameMode::Foo(bool bPause)
{

}

Would be great to hear any thoughts, I just upgraded to 4.17 as well.
Thanks.

There are two possibilities here:

Are you using your GameMode in your game (i.e. is it setup in the Project’s settings?)
If so, make sure you cast the result of “Get Game Mode” to your specific class.
If you are using a BP which has your C++ Class as Parent, your Event may be under “Call Function”.

Also uncheck the Context Sensitive checkbox in your BP when searching for your method.

Check this

Thanks all, I tried all what you guys mentioned to no luck - it turns out I was running the solution under the wrong solution configuration. I’ve changed it to ‘development editor’ and it seems to have been picked up fine now!