Can't see C++ classes in content browser

I opened a 4.26 C++ project in UE5, but can’t see my C++ classes
I tryied to regenerate VS files and recompile, still nothing
I tryied to add new C++ classes from the editor (Tools → Add new C++ class), the .h and .cpp files are created but still no “C++ classes” folder in the content browser. I tryied regenerated VS file and recompile : nothing.
Obviously, the “show C++ classes” setting is checked and the folder is visible in content browser while creating a blank C++ project but not in an already created project.

Any help please?

Any ideas on this? I have the same problem, except that I started a new UE5 project instead of converting one from UE4.

When I create a new C++ class in UE5 it does not appear in the content browser. It’s simply not there.

I am in the C++ classes folder, I do not have any filters on, I can see the game mode C++ class that is already there when creating a new project. The only suggestion I found when googling was to delete all the derived files and rebuild the project. It did not work. Restarting the engine does not help.

Am I missing something or is this a bug? I do not have this problem in UE4.

So, it turns out that I was creating a new class of type none, which has a header that is not by default compatible with Unreal. Other classes, like Actor, do work.

Ran into the same issue. Did you figure out how to remove those classes? I tried removing them from the solution in VS, but UE still wont allow me to create a new class with the same name.

Found a solution here How do I remove a C++ class from my project code? - #5 by Co
But in my case it was easier to just purge the project and start from scratch as I had noting in it yet.