Can't scale a mirrored mesh without it squishing?

Hey ,
No way is this intended. It hasn’t worked this way in previous versions of UE4 and UE3 or any popular modeling software for that matter. The workflow you suggested is extremely slow. Imagine you’re filling a scene with foliage and you want to mirror and scale meshes on the fly to add variety. Having to type numbers into the scale fields by trial and error is a workaround for this bug. Also, try scaling a mirrored mesh in a blueprint and you’ll see that it works as intended.
Sorry to be so impassioned about this but It’s a serious hamper on my workflow. Up until UE4 4.9 it has worked just fine (… not sure about 4.8 since we skipped that rev).

Hello ClaCla,

I was able to reproduce this issue. However, this is intended behavior. What happens is when you mirror an object you have changed the coordinates of whatever axis that you have mirrored the object over. For instance, I mirrored the set of stair cases around the x axis. When I did this it changed from it’s usual positive value to that of a negative one. This does not change the values from positive to negative for your Y and Z values. What happens when you use the scaling tool now is it tries to scale all of the your XYZ values in the positive direction. What should be happening is while your x value decreases your Y and Z values will increase in respect.

In order to ensure that this does not happen you can go to the Scale Values in the details panel of your mesh. On the right hand side of the XYZ sliders there is a lock icon. By default it is unlocked allow for non uniform scaling on the Axis that you want. Click this on to lock all of the different Axis. Then adjust the negative value of the axis that you mirrored. Your positive values will scale respectively. So if you change this to a value of -4 then the other values will scale to positive four.

You are absolutely right. After further investigating and testing I was able to reproduce this. It does work as intended in 4.7.6.

Currently there is a ticket opened for this fix. The ticket number is UE-16758.

However, this issue has been backlogged. I do not have an ETA for when this issue will be resolved. I will keep you updated with any progress.

great, thanks!