Download

Can't Save Procedural Mesh Component Blueprint

I have seen several posts about failure to save the umap file with the “Graph is linked to private object(s) in an external package”. Some posts indicate that the problem was solved for some instances, such as blueprint library functions calling other functions in that library:

https://answers.unrealengine.com/questions/199154/blueprint-function-library-cant-save-graph-is-link.html

However I am still having that error when trying to save any blueprint that has been placed in the level when the blueprint contains a procedural mesh component written in C++. If I create a procedural mesh actor in C++ which uses this mesh component, and then place the actor in the blueprint it saves fine. However I need to create just procedural mesh components. The procedural mesh component example project includes several procedural actors (ProceduralCubeActor, ProceduralLatheActor, etc), and a ProceduralMeshComponent. Creating a new blueprint, adding the ProceduralMeshComponent to the blueprint, and placing that blueprint in the scene causes the save error.

Will this bug be fixed?

(BTW, I just installed and tried 4.7.5 and it had the same issue)