Can't save checked out files

So I’ve been working on a project with other folks and we use Perforce as our file sharing software. Just recently I started getting an error when I tried editing a file I had checked out. I’ve tried a bunch of different files as well as checking out the files in-engine and through Perforce with the same results. No one else has the files checked out and I have full permissions on the Perforce server.

You do not have sufficient permission to save the following content to disk. Any changes you make to this content will only apply during the current editor session.


Hey Ferornic-

Can you elaborate on what’s happening? So far I have been able to check out an actor blueprint, edit the blueprint by adding components and variables, and then save / check in the blueprint. Can you tell me what type of blueprint you’re using? What edits were made that required a save? If you have the same issue with saving after creating a new blueprint can you walk me through the steps that lead to the error message?


The file I’ve been trying to work on is a UMG file. Though I’ve tried checking out a blueprint and a map with the same results. As soon as I edit the file in any way, the prompt comes up saying I don’t have permission to save the file. I just tried making a new file to submit to Perforce and the same error came up, saying I don’t have permission to save.

On a whim, I opened up a project that doesn’t have a connection to source control, and I’m getting the same error. The engine crashed 4 times trying to open it too (all the crashes said there was no minidump).

I’ve not had any issues before a couple of days ago.

To confirm you get the same error trying to save when connected to source control as when not connected? Was the second project you tested one that already existed or a new project that you created? If it was an already existing project can you test if you have the same issue with saving a blueprint in a new project?

After messing around in Windows Explorer for a bit I found out that my entire Unreal Projects directory was being shared with my local network as well as with Perforce. I unshared it and now all of these problems have disappeared.

Anyways, thanks for giving me a hand with this. Here’s hoping it’ll be useful to someone else.