Can't run packaged project with plugins for that project

Hello.

In my previous bug report Hot reload seems broken in project with Plugin - Possible bug - C++ - Epic Developer Community Forums I reported to your team that Project with plugin after compilation from UE Editor can’t be saved - it’s gets errors on save.

But that’s not the end of the story of the Project with plugins…

After packaging of that Project - game exe crashed with no errors in logs. It’s not generated log files, it just silently crashes…

Project sources: https://goo.gl/htX4Xe
Built project: https://goo.gl/p6x9Lf

Can you explain, why it crashed without no information about crash?

But in Windows logs I found error:

Контейнер ошибки 120274677119, тип 4
Имя события: APPCRASH
Отклик: Нет данных
Идентификатор CAB: 0

Сигнатура проблемы:
P1: HOTRELOADTEST.exe
P2: 4.8.1.0
P3: 559e3d04
P4: HOTRELOADTEST.exe
P5: 4.8.1.0
P6: 559e3d04
P7: c0000005
P8: 000000000036501c
P9: 
P10: 

Вложенные файлы:
C:\Users\\AppData\Local\Temp\WER5266.tmp.WERInternalMetadata.xml

Эти файлы можно найти здесь:
C:\Users\\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_HOTRELOADTEST.ex_750ea75e2f08ec17ab687f4a959ccc46c914271_d98a345c_20425748

Символ анализа: 
Повторный поиск решения: 0
Идентификатор отчета: 25d6cac3-261d-11e5-bf13-fc4dd451925d
Состояние отчета: 0
Хэшированный контейнер: 687a870ec593dd3bb0c879926259f561


Имя сбойного приложения: HOTRELOADTEST.exe, версия: 4.8.1.0, метка времени: 0x559e3d04
Имя сбойного модуля: HOTRELOADTEST.exe, версия: 4.8.1.0, метка времени: 0x559e3d04
Код исключения: 0xc0000005
Смещение ошибки: 0x000000000036501c
Идентификатор сбойного процесса: 0x23f0
Время запуска сбойного приложения: 0x01d0ba29e820328f
Путь сбойного приложения: C:\temp\MyGameBuild\qqq\WindowsNoEditor\HOTRELOADTEST\Binaries\Win64\HOTRELOADTEST.exe
Путь сбойного модуля: C:\temp\MyGameBuild\qqq\WindowsNoEditor\HOTRELOADTEST\Binaries\Win64\HOTRELOADTEST.exe
Идентификатор отчета: 25d6cac3-261d-11e5-bf13-fc4dd451925d
Полное имя сбойного пакета: 
Код приложения, связанного со сбойным пакетом: 

Thank you!

Hi ,

Are you able to see crash logs at WindowsNoEditor\YOURPROJECT\Saved\Logs?

Does your packaged project currently contain the plugins that can’t be saved, from the other issue?

Thanks!

Hi!

As I said “It’s not generated log files, it just silently crashes…”. Packaged game, what I tried to start is in archive https://goo.gl/p6x9Lf . No, there are no logs…

Yes, it contains plugin from other issue. All code saved correctly (but after many of UE Editor restarts).

I asked author of the project of the plugin here Epic bug with plugins for project. · Issue #9 · Jusas/SQLite3UE4 · GitHub and he said:

This is somewhat a mystery to me, I originally created the code for UE 4.6 and tested packaging with it and at that time it seemed to work just fine. Looks like it’s crashing on an access violation. That’s pretty much all I can tell, I’ve only worked with 4.6 and I’m not currently actively developing anything with UE4 for the time being so I’m afraid I’m not of much help at this time.
As for plugin hot reloading, it wasn’t available back in 4.6 so I’m afraid I can’t help you with that either.

I just made some improvements for project of the SQLite3UE4, I am not author of the SQLite3UE4.

Thank you!

Do you get the same crash when the problematic plugins are disabled for your project? There’s been many changes since 4.6 so it’s possible, since the creator has not continued to update the plugin in the interim that they’re no longer compatible with the current version of the engine.

If this plugin disabled, packaged game starts well.

I have read Plugins in Unreal Engine | Unreal Engine 5.2 Documentation and A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums and compared sources with wiki.

Can you review my sources (GitHub - KhArtNJava/SQLite3UE4: SQLite3 Database Plugin for Unreal Engine 4) or Jusas’s sources (GitHub - Jusas/SQLite3UE4: SQLite3 Database Plugin for Unreal Engine 4) of the plugin as UE staff :slight_smile: ?

If you will find error, which differs with tutorials and which arise crash, I will be very grateful to you. You will save me my time - because in my game I’ve programmed a lot of code and BPs, based on SQLite3UE4 plugin.

The same interesting moment in this bug is that if I start my game from UE Editor - it’s works perfectly! But it doesn’t work, when it was packaged.

I think, it may be bug in packaging system of the UE.

If it packages well without the plugin, it is not a bug in UE4.

Unfortunately, we aren’t going to be able to help you with the abandoned plugin.

We cannot be responsible for content created by other community members. If your project relies heavily on the plugin then it may be best to stay on an engine version that is compatible with the plugin. If you do need to update the engine version for other features then you will have to contact the plugin creator for an update.

Good luck!