Can't run game in standalone or package Engine Upgrad (4.18.3 to 4.21.2)

Since I have my game in source control I can go back and forth between my game running in UE 4.18.3 which runs fine in standalone and can be build and packaged and the game after upgrading to 4.21.2. The only difference is the new engine version. With 4.21.2 the engine crashes during loading when I try to run it in standalone mode and the cooking process failes as well.

I can’t think about anything that is causing this issue other than maybe some plugin or whatnot but everything should support 4.21. There are some errors in the log but thats not always causing complete crashes like that. Is there anyway to pinpoint to some specific thing in my logs that tell me where the actual crash comes from? Like a specific plugin or script?


The log and cook are kind of worthless without the debugging symbols.

You could get more information about what’s happening if you build the engine from source and then run it in debug mode from Visual Studio.

Or at least that’s what I would do, don’t know if there’s a way to get debugging symbols on a packaged engine version.

First thing you might try is replacing all the deprecated functions with the new intended ones. Also, look at the other warnings and try to solve them, they might be the cause of the crash.

Thanks for the reply. I did have some warnings about deprecated functions which I fixed, including a few other warnings but I can’t get rid of the crashes. I’ve also enabled the debugging symbols now and have to more logs with them activated.
Log Cook

There are basically only to errors left really but I don’t really know what to do with them one is “LogLinker: Warning: Unable to load PhysicsSerializer with outer InstancedStaticMeshComponent”
and the other “Ambiguous search, could be StructProperty”

I’ve found some people who went through all their blueprints and found some that would crash the editor while opening, but that doesn’t seem to be the case for me here. I couldn’t find any behavior like that.

Ugh, still doesn’t help much, it’s just “some blueprint node failed to serialize because it’s referencing/connected to something that doesn’t exist”
(That’s what I would understand from the source).

Possible things to try -
a) try going through the intermediate engine versions, updating the project step-by-step
b) build the engine from source, run it in debug mode from VS and then when this happens you’ll have a full call stack which will show you which blueprint this is about (this is obviously quite a hassle, but will help you immensely with any mysterious engine crashes)

(if your project isn’t anything sensitive, pm me on the forums, I could run it on my machine and see what the debug says)

Okay I’ve already built the engine in VS but thought I might get what I need by just activating the debugging symbols. I’ll try that next then and if I can’t get it running properly through VS I’ll PM you.

Definitely thanks so far

Okay, I was able to run the game in standalone mode (PIE) and complete the packaging process now and all under 21.2.

Sadly I didn’t really figure out what the actual problem was. After fixing most of the errors and warnings I recognized most of the errors left were linked to a marketplace plugin for procedural foliage creation. I’ve stopped using this plugin in this project but there were still some references left in some blueprints so I couldn’t delete the folder yet. However I did delete it now, fixed all the broken references and Then everything worked.

The plugin itself should work perfectly fine under 21.2 so I don’t quite understand why this was an issue but at least it is working now.