Can't Run 4.7.2

Hi,

I installed version 4.7.1 few days ago and I haven’t any problems with launching Unreal Editor. I upgraded the engine to 4.7.2 today and now I’m getting crash everytime when I try to open Unreal Editor - it crash during initializng at 45%. I can open launcher but not editor.

Crash report data:
MachineId:33A76F2B49C5381D253AF49444B355CA
EpicAccountId:0f6da742e87143f99f648d780b7c5aa0

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: SerializedElementSize == 0 || SerializedElementSize == ElementSize [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 1227]
Expected 1, Got: 1111572549

KERNELBASE + 24684 bytes
UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 292 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
UE4Editor_Core!FDebug::AssertFailed() + 1079 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
UE4Editor_Engine!TArray >::BulkSerialize() + 286 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\containers\array.h:1232]
UE4Editor_Engine!FRawStaticIndexBuffer::Serialize() + 332 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\rawindexbuffer.cpp:229]
UE4Editor_Engine!FStaticMeshLODResources::Serialize() + 320 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\staticmesh.cpp:304]
UE4Editor_Engine!TIndirectArray::Serialize() + 325 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\containers\array.h:3030]
UE4Editor_Engine!FStaticMeshRenderData::Serialize() + 108 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\staticmesh.cpp:622]
UE4Editor_Engine!FStaticMeshRenderData::Cache() + 297 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\staticmesh.cpp:1138]
UE4Editor_Engine!UStaticMesh::CacheDerivedData() + 236 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\staticmesh.cpp:1660]
UE4Editor_Engine!UStaticMesh::PostLoad() + 459 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\staticmesh.cpp:1848]
UE4Editor_CoreUObject!UObject::ConditionalPostLoad() + 455 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\obj.cpp:628]
UE4Editor_CoreUObject!EndLoad() + 1724 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1121]
UE4Editor_CoreUObject!LoadPackageInternal() + 2274 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:904]
UE4Editor_CoreUObject!ResolveName() + 1483 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:610]
UE4Editor_CoreUObject!StaticLoadObject() + 655 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:697]
UE4Editor_Engine!ConstructorHelpersInternal::FindOrLoadObject() + 609 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\public\uobject\constructorhelpers.h:33]
UE4Editor_Engine!ConstructorHelpers::FObjectFinder::FObjectFinder() + 192 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\public\uobject\constructorhelpers.h:91]
UE4Editor_Engine!UCameraComponent::UCameraComponent() + 112 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\camera\cameracomponent.cpp:24]
UE4Editor_CoreUObject!UClass::CreateDefaultObject() + 435 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\class.cpp:2506]
UE4Editor_CoreUObject!FObjectInitializer::CreateDefaultSubobject() + 569 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:2644]
UE4Editor_Engine!ACameraActor::ACameraActor() + 197 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\camera\cameraactor.cpp:20]
UE4Editor_CoreUObject!UClass::CreateDefaultObject() + 435 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\class.cpp:2506]
UE4Editor_CoreUObject!UObjectLoadAllCompiledInDefaultProperties() + 805 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:739]
UE4Editor_CoreUObject!ProcessNewlyLoadedUObjects() + 146 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectbase.cpp:815]
UE4Editor!FEngineLoop::PreInit() + 9281 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launchengineloop.cpp:1308]
UE4Editor!GuardedMain() + 251 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:110]
UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Hi Xijanik,

Try this. Open Launcher, Select Library tab, click on add versions, load latest available (ie 4.6.1) -or if you already have it, run it. Create a new blank Project and save it. Close editor. Go back to library and rmb 4.7. Chose “verify.” After verifying, Open 4.7.2 to open the blank project you just created.

If it opens, try opening the project you were working on in 4.7.1. If it does not open, that means something from the original project is not compatible with 4.7.2.

If also generated a bug report: JIRA [UE-11429]. Let me know if following the steps above did not resolve your issue.

Thanks

Hi Steve,

Thank you for respond. I installed 4.6.1 to check if this version will work for me. It’s working without issues. I haven’t any “my” projects since I’m at begining of my journey with UE4. So like you suggested, I’ve made blank project in 4.6.1, after that I went to …documents/unrealprojects/ and clicked right mouse on blank project and I “Switched unreal engine version” to 4.7. It’s like before, it crash when it show “Initializing” at 45%.

I was removing and downloading 4.7.2 version few times and nothing has changed, any solutions? Is there also an option to donwload 4.7.1 version again? I’m asking because in launcher I can only choose from 4.7.2, 4.6.1 and older ones, there is no 4.7.1.

Can you also tell me what “rmb 4.7” mean?

Hi Xijanik,

“rmb 4.7” it is short for, “right mouse button” -but it turns out it lmb or “left mouse button” but you figured it out. Unfortunately you can only download the latest released version of the engine (ie 4.7.2 but not 4.7.0)

As I mentioned before, I’ve put in a bug report so maybe a developer can shed some light on why you are experiencing this issue. It may have to do with the type of system you are running on. What version of Windows are you on? Also, please post a copy of your Dxdiag. (I’ve heard people running Windows Vista can run 4.6.1 but not 4.7)

Thanks

Hi,

I’m using Windows 8.1

Is there any other way to give you Dxdiag? I was trying to attach this file but it won’t start to upload, it stay at 0%… I have no idea why… I’ve tried upload with 3 web browsers.

You can put it in a zip file and attach it or use Dropbox or Google drive and provide a link to it.

-Thanks

Hi,

Thanks for tip, here is the file:

DxDiag

Hi Xijanik,

Can you try clearing out your DDC and see if that helps?

(delete DerivedDataCache folder from C:/Program Files/Epic Games/4.7/Engine/ )

Let me know if that helps!

Just following up… Have you tried Allan’s suggestion? Allan is one of our developers working on the issue.

Hi,

By “clearing out” I understand delete some files? In DerivedDataCache folder I had one file Compressed.ddp and I removed it, than I removed also DerivedDataCache folder. Nothing has changed, it crash during “Initializing” at 45%.

Ok. I cant reproduce the crash here. I’m trying to source a machine with a similar setup to yours.

In the meantime, from the crash log it looks like its trying to load your project ’ UE4-MyProjectBlank’ try renaming that and starting the editor again.

If that helps i’d really appreciate a copy of the project to help repro at my end (if that is ok with you of course)

I don’t have it anymore since I was installing and uninstalling engine few times. About project, it was simple first person project from what I remember. I created project with the same name “MyProjectBlank” today but in 4.6.1 (this version is working for me), than changed to open in 4.7 and crashed also at 45%. Maybe I should unistall again and clear some files in “regedit” or something…

Are you still experiencing this issue? Have you tried updating to 4.7.3? If so, have you tried launching 4.7.3 and opening a blank project. If that works can you launch 4.7.3 then open a copy of your 4.6 project through the launcher?

Let me know if any of these work for you -thanks.

I updated to 4.7.3 and the same issue, it crash during initializing 45%. I was trying to open project made in 4.6 but it also doesn’t work.

Just to let you know, we’ve been trying to repro this here for the last couple of days. still no luck :frowning:

What happens if you open the editor without a project? (maybe rename the folder of your current project?). does it start? can you create a brand new project without problems?

I could open editor in 4.6 and create/open any new project. In 4.7.2 and now 4.7.3 I can’t even open editor since it crash at 45% during initalizing proces. I uninstalled both version and launcher today, cleared all (I think) files releated to “Epic Games” and “Unreal” in regedit. Than I installed fresh 4.7.3 and still no luck. I was suprised that when I installed launcher again it remebered my e-mail address… Can you tell me where launcher keeps those data?

I also updated my GPU drivers (nvidia) to the newest ones, I’m using now 347.88 - nothing has changed.

Here are the instructions on how to completely remove UE4:

 Uninstall UE4 either through the control panel or the Remove option on the Launcher

installer

 Desktop icon <-Should disappear on its own. If it doesn’t, delete.

 C:\ProgramData\Epic <-Delete this folder

 C:\Users\paul.shank\AppData\Local\UnrealEngine <-Delete this folder

 C:\Users\paul.shank\AppData\Local\UnrealEngineLauncher <-Delete this folder

 C:\Users\paul.shank\Documents\Unreal Projects <-Delete this folder

 C:\Program Files\Unreal Engine <-Delete this folder

 To be safe, empty recycling bin

Hi,

Thank you for that info. I decided to reinstall my Windows. I’ve cleared my system partition and installed “fresh” system. It worked! I don’t have any problems during opening and creating projects in 4.7.3.

I have no idea what was the issue before but I’m glad that this solution worked for me. I hope I will not get any issues in the next few days :wink:

Thank you all for your time and effort to help me with resolving above issue! I really appreciate it.

Best regards.

I’m glad you got this resolved. I was going to suggest that, but that is always considered a “last ditch” effort. Please let us know if you experience any further issues. -Thanks