Cant reopen project after checking in sequencer files (Perforce)

After working in sequencer and submitting my changes into perforce I cannot reopen the project. the editor fails to load at 45% I can open a new or blank project. I’ve tried reverting my changes, uninstalling/reinstalling Unreal, Our programmer has been trouble shooting this with me for over a week. the only thing we have found to work is completely doing a system reset. starting with a totally blank slate and reinstalling everything. I’ve had to do this 2 times. and I just ran into this issue again for the third time. the strange thing is anyone else on the team can sync up to my changes and open the project no problem. even after I get my system back up and running I can sync to the latest including the changes that could have potentially caused the problem in the first place and the project loads up with out any issues. I only have an issue after working in sequencer. and this did not happen in 4.14. I was using sequencer just as much if not more over the last couple months and never had any problems like I have been getting in 4.15.

Hello johnbingham,

Could you upload a log file from one of the sessions where this failed to load at 45%, as well as a log from where you submitted the sequencer file to perforce, if you still have it? It may be able to explain where this issue is occurring in the loading process.

Have you tried disconnecting Source Control from the project to see if the source control part of things is what is causing this? You can do this manually by deleting the SourceControlSettings.ini file in the project’s directory under Saved/Config/Windows.

Here is the log from the project crash report. Im not aware of a log that records where/what files are submitted to perforce other than the revision text

Thank you for that log. As for the other one, I meant the editor log still, just from the session where you made the commit that ended up causing this error.

The log you provided, this is just the log from trying to open the editor, correct? It’s filled with messages about not being able to find “‘/Script/MaelstromV2’” while trying to load multiple different assets and is eventually trying to load
“NULL” assets as it’s failing to load the parent classes for multiple blueprints. It eventually runs out of space while trying to load all of this and fails.

I’m not privy to your file structure in your project but I would suggest looking at what is in this /Script/MaelstromV2 folder and also trying to disable source control in the project as I mentioned previously.

Edit: I apologize, I spaced on that for a moment. The /Script/MaelstromV2 is related to your config folders actually. Could you try making a copy of your Config/Saved folders and then removing them from the project to effectively reset your configuration settings?

Hey Matthew Thanks for your help. I followed the instructions you added to your last comment and it worked. deleting the saved folder entirely from the Engine 4.15 file structure worked.


it takes a bit of time for the editor to load the project but its a great work around.

Thanks again,

In my case, the editor crashed while rendering a sequence (then fatal error @ 45 % on restart) and there was a leftover sequencer render script inside this file:


It was basically a script with the render settings that I used:



As soon as we cleared the script everything was fine.

It may be a good idea to sort this out, because in my team there are a lot of people encountering this problem. I started using Unreal from version 4.14 and it has been happening ever since (4.15, 4.16)

P.S.: kudos to my programmer colleagues sorting this out :slight_smile: