Download

Can't remove widget in the UMG Hierarchy?

I have a UMG Widget Blueprint with a Hierarchy as shown in the following screen shot.

I’m trying to remove the Overlay widget so the Size Box below it sits directly inside the Background Blur. I cannot for the life of my figure out to remove the Overlay widget.

I tried just deleting it, but that obviously took all of its children with it.
I tried to cut the children, delete it, then paste the children back, but that breaks all the Blueprint code that then needs to be fixed by hand.
I tried dragging the Size Box up on to the Background Blur, but the Background Blur will only accept one child, so it won’t let me do that.

I’m stuck! I can get around this one for now using my second option above, but I need to find a better way for the future. My game is UI intensive so I have a lot of UMG that I’m constantly changing all over the place and I run into this issue every day with different scenarios. Surely there has to be an easier way to remove a widget from the hierarchy and just push all its children up? If not, then maybe I should go make a feature request?

Right click an element in the Hierarchy and ReplaceWith… Child to remove it.
Right click an element in the Hierarchy and WrapWith… AnotherElement to add one.

I have had this issue too, I assume it’s a bug when the state gets confused. An editor restart usually fixes this for me.