Can't Remove Gameplay Abilities or Effects

I have a gear system in my game that’s pretty simple. When a character has an item in an equipped slot, I want to give them an increase of 10 health. This works great. They have the health, I’ve granted them the ability, etc… However, when they remove the item, I want to remove that +10 health. I’m losing my mind just getting this to work. It will NOT remove the ability.

Here is my character class that gets the ability. The “Add Ability” section works great, but the remove ability does not.

I’ve also tried this:

In my added ability, it’s really simple. I’ve given it the Gear.Primary tag in the class defaults and applied this effect.

In my remove ability, I have this:

And in the effect for the remove, I have this:

I’m at a total loss for how to fix this. I’ve tried removing effects manually, I’ve tried removing tags through the abilities and effects. I simply don’t know what I’m doing wrong. If anyone could please help. I would sure appreciate it.

Thank you

I don’t know much about this, but I don’t see the ClearAbility node, or EndAbility.

I just saw them on the doc page: