Can't remove deleted blueprinted pawn object from Level outliner in UE 5.0.1

Hello there, I am encountering a problem removing ‘Pawn’ object from level scene.
I added a ‘Pawn’ actor named ‘Pawn 2’ and added a blueprint class inherited from it, then I deleted the blueprint in the content asset tab, when I wanted to remove ‘Pawn 2’ from the ‘outliner’ tab for the level scene item list, the ‘Pawn 2’ became grey and I can’t seem to remove it via key ‘Back’, and I got a warning saying failed to load Pawn 2 when restarting the project.

The problematic ‘Pawn 2’ in outliner:

Thanks in advance.

Are you still playing, and you hit F8?

I think when you stop playing, this reference will go away.

Thanks for the quick reply, though I tried stopping/restarting the project, but neither did work -.-

Ah, I think it’s to do with world partition. That pawn is in an unloaded level?

nope, I just deleted it from the content browser tab and it suddenly became ‘unloaded’ status in default level named ‘untitled’, which is the only level actived/existed in whole project.

The default level has world partition set up.

Thanks I will give it a shot.

I tried disabling world partition and word partition streaming but no avail.
It seems it always tries to find an Actor named Pawn 2 ( Create Export: failed Game/Untitled/Pawn_2_C gui xxx blahblah)
I tried searching the Actor ‘Pawn2’ but the nothing in content browser directory or blueprint reference.
The ‘Map Check Error’ doesn’t seem to have any impact on the actual scene or packaging into windows binary, but it’s still a pain in the ■■■ to pop up a error message everytime you start the project. -.-

1 Like

Hello! Did you able to fix this? I am facing the same problem. Asset cant be deleted from the scene because of the unloaded state after I deleted the blueprint.
Restarting the engine and unloading the level doesnt help.

Unfortunately I only found the workaround mentioned above, really can’t find a proper way,of removing a in–scene object based on a deleted pawn class.
Hopefully someone will find a proper solution to this glitch.
Good luck.–_–

Hi. It happened to me as well a few times. It’s related to how World Partition works. You can try to open the World Partition tab (from Window > World Partition > World Partition Editor), select all the cells, then right-click and choose “Load selected cells”. In this way, it should reload all those actors that in the Outliner are shown as “unloaded”.

Hope this helps.

Same issue here. I’ve deleted the actor from my level and the Content Browser, and it is still showing up in the outliner.

I’m getting this error:
CreateExport: Failed to load Outer for resource ‘Root’: BPP_Dominos_LP_C /Game/Maps/Gym_WP.Gym_WP:PersistentLevel.BPP_Dominos_LP_C_UAID_04D9F5F7D4CA122001_1809927177


Found a fix, maybe this works for you: UE was crashing when launching the level because of the unloaded pawn, tried fixing it with enrico.lapponi’s solution but it didn’t exactly work, I enabled the option but when I selected the cells and loaded them nothing seemed to happen, but when I deactivated the option, the engine crashed and when I reloaded the project file the pawn was no longer there and could play the level normally again

TLDR: Enable world partition Streaming, select all cells and Load them, Disable world partition Steaming, it may crash when disabling World Partition Streaming but close and reopen the project file if it didn’t. That fixed it for me.

1 Like

Nice, I’ll give it a try. Thanx for the help.

That worked, thank you. And the engine didn’t even crash. :slight_smile:

Enable world partition editor, selecte the area where the pawn/object was inside (you can find it by zooming in because world partition editor is like a map of your world), right click and go with unload cells, right click again and do load cells and you should be able to see the pawns/objects appear in the world, select them to delete if you want them deleted.

I found a more permanent solution, I right clicked the (unlocked) item, in my case was BP_Door and I clicked copy selected actor path, I pasted it into File Explorer, minus the file name (just directories, then deleted the file, worked for me :smile:

1 Like